Ruby Scaffolding with old Rack app

I’m trying to build Hurl, as it turns out that the National Parks app that I’ve been using doesn’t seem to make any outbound http requests, so I can’t use it with my outbound proxy, for demo purposes.

Hurl is ideal - it uses postgres, and makes http requests.

It’s very old, but it seems to do the trick - you can see it in action here.

I’ve tried to use the Ruby scaffolding, with some success. I built a Ruby 2.0 because the Gemfile specifies Ruby 2.0, and the app builds.

However, the libexec/is_db_connected.rb is looking for a config/environment.rb which I think isn’t needed.

The model is pretty straightforward (and interestingly looks like it could use Redis), and also doesn’t use ActiveRecord, so even if I force is_db_connected to pass, I get stuck at this point.

It may be that I am just asking too much for the scaffolding to work for such an ancient app, but if it can be made to work (with Redis would be fine), that would be great.

I tried setting an environment variable to use the ‘file’ backend, after looking at the model, but the supervisor still wants to have a database connection, presumably because it saw the pg gem.

Any thoughts on this most welcome.

My apologies on not getting around to respond to this sooner. Is this still something you’re working through @sns ? The scaffolding is quite limited in scope but I believe you should be able to use scaffolding apps with redis, I’m not the most versed in them but we can definitely get this figured out if you still need help with it.