[SOLVED] Fqdn in generated knife.rb not updated, but config is?


#1

I moved a chef server into a new virtual network and consequently, its FQDN changed.

I did a reconfigure and restart and show-config.

The chef-server-ctl show-config shows the right info:

  "api_fqdn": "chefserver.pubsubnet.utilitiesvcn.oraclevcn.com",
  "web_ui_fqdn": "chefserver.pubsubnet.utilitiesvcn.oraclevcn.com"

However, when I generate a new knife.rb or download the starter kit, the “chef server url” in the downloaded kit is wrong:

It says:

chef_server_url
"https://chefserver.sub11271359160.publicprivatevc.oraclevcn.com/organizations/ecateam"

Where is it getting the chef_server_url from in the generated knife.rb/starter kit?

I’m concerned this is going to cause the ssl stuff to fail if the fqdn is wrong internally somewhere.

Job


#2

It helps when you read the whole help page.
The last line said:
Change Hostname of Chef Server

Change Hostname of Chef Server

To change the hostname on Automate/Chef Server/Compliance on AWS Marketplace installs, refer to the links found …

If you want this new config to flow through into Manage and the knife.rb that it can generate in the starter kit, please also do the following

chef-manage-ctl reconfigure

–Problem hopefully solved now!

jobmiller
January 6 |

I moved a chef server into a new virtual network and consequently, its FQDN changed.

I did a reconfigure and restart and show-config.

The chef-server-ctl show-config shows the right info:
“api_fqdn”: “chefserver.pubsubnet.utilitiesvcn.oraclevcn.com”,
“web_ui_fqdn”: “chefserver.pubsubnet.utilitiesvcn.oraclevcn.com

However, when I generate a new knife.rb or download the starter kit, the “chef server url” in the downloaded kit is wrong:

It says:

chef_server_url
"https://chefserver.sub11271359160.publicprivatevc.oraclevcn.com/organizations/ecateam"

Where is it getting the chef_server_url from in the generated knife.rb/starter kit?

I’m concerned this is going to cause the ssl stuff to fail if the fqdn is wrong internally somewhere.

Job

Visit Topic or reply to this email to respond.

You are receiving this because you enabled mailing list mode.

To unsubscribe from these emails, click here.