Subversion control files in templates on chef-server on rake install


#1

Hi,

I’m using Chef 0.9.6 on CentOS 5.5 with Subversion 1.6.12
Chef installed from ELFF/EPEL repositories.

I’m hosting my Chef repository on a Subversion server.
I’ve found that during a “rake install” task, files from
"cookbooks/<my_cookbook>/templates/.svn directory get published on Chef server.

How to avoid this? Is it possible to specify a filter or exclude option
somewhere?

Thanks


#2

This looks like it would require a patch - feel free to file a ticket. :slight_smile:

Adam

On Mon, Jul 26, 2010 at 2:20 AM, Vladimir Girnet
vgirnet@tacitknowledge.com wrote:

Hi,

I’m using Chef 0.9.6 on CentOS 5.5 with Subversion 1.6.12
Chef installed from ELFF/EPEL repositories.

I’m hosting my Chef repository on a Subversion server.
I’ve found that during a “rake install” task, files from
"cookbooks/<my_cookbook>/templates/.svn directory get published on Chef server.

How to avoid this? Is it possible to specify a filter or exclude option
somewhere?

Thanks


Opscode, Inc.
Adam Jacob, CTO
T: (206) 508-7449 E: adam@opscode.com


#3

Actually, there is an undocumented feature that looks like it might
work for this. You can put regular expressions matching files you wish
to be ignored in a file named “ignore” at the root of your cookbook. I
haven’t tried it, but if you put something like

\.svn

in that file, it should ignore your .svn directories. Unfortunately, I
think you have to do this on a per-cookbook basis.

Let us know if it works out.

Dan DeLeo

On Tue, Jul 27, 2010 at 4:53 PM, Adam Jacob adam@opscode.com wrote:

This looks like it would require a patch - feel free to file a ticket. :slight_smile:

Adam

On Mon, Jul 26, 2010 at 2:20 AM, Vladimir Girnet
vgirnet@tacitknowledge.com wrote:

Hi,

I’m using Chef 0.9.6 on CentOS 5.5 with Subversion 1.6.12
Chef installed from ELFF/EPEL repositories.

I’m hosting my Chef repository on a Subversion server.
I’ve found that during a “rake install” task, files from
"cookbooks/<my_cookbook>/templates/.svn directory get published on Chef server.

How to avoid this? Is it possible to specify a filter or exclude option
somewhere?

Thanks


Opscode, Inc.
Adam Jacob, CTO
T: (206) 508-7449 E: adam@opscode.com


#4

I can’t test this right now, I’ve moved my repository to git.

I’ll try “ignore” option sometimes later.

Daniel DeLeo wrote:

Actually, there is an undocumented feature that looks like it might
work for this. You can put regular expressions matching files you wish
to be ignored in a file named “ignore” at the root of your cookbook. I
haven’t tried it, but if you put something like

\.svn

in that file, it should ignore your .svn directories. Unfortunately, I
think you have to do this on a per-cookbook basis.

Let us know if it works out.

Dan DeLeo

On Tue, Jul 27, 2010 at 4:53 PM, Adam Jacob adam@opscode.com wrote:

This looks like it would require a patch - feel free to file a ticket. :slight_smile:

Adam

On Mon, Jul 26, 2010 at 2:20 AM, Vladimir Girnet
vgirnet@tacitknowledge.com wrote:

Hi,

I’m using Chef 0.9.6 on CentOS 5.5 with Subversion 1.6.12
Chef installed from ELFF/EPEL repositories.

I’m hosting my Chef repository on a Subversion server.
I’ve found that during a “rake install” task, files from
"cookbooks/<my_cookbook>/templates/.svn directory get published on Chef server.

How to avoid this? Is it possible to specify a filter or exclude option
somewhere?

Thanks


Opscode, Inc.
Adam Jacob, CTO
T: (206) 508-7449 E: adam@opscode.com


#5

On 28 July 2010 01:49, Daniel DeLeo dan@kallistec.com wrote:

Actually, there is an undocumented feature that looks like it might
work for this. You can put regular expressions matching files you wish
to be ignored in a file named “ignore” at the root of your cookbook. I
haven’t tried it, but if you put something like

.svn

in that file, it should ignore your .svn directories. Unfortunately, I
think you have to do this on a per-cookbook basis.

Let us know if it works out.

Hello,

I’ve tested this out on my 0.9.6 server test server which has a svn
repo behind it and it seems to work fine.

Cheers, Gavin