Trouble seeing chef-server webui


#1

Hi Guys,

I’m trying to setup the open source chef-server. I seem to have set
everything up correctly but for some reason when I go to the url of the
server in my browser I only see the nginx default screen. When I type
chef-server-ctl test, all the tests pass. I’ve been searching online for
steps to install the server and all of them only say that once you run
chef-server-ctl reconfigure you should be able to go to the url in your
browser and the chef-server webui should be displayed. Could someone point
me in the right direction please

  • Thanks
    Ameya

#2

It should have worked, but it obviously didn’t. Are you seeing any kind
of errors from nginx? You can watch the nginx logs with “chef-server-ctl
tail nginx”. If you need more logs, you can leave off the nginx and just
try “chef-server-ctl tail”. You could also watch the webu lgosi and see
if it is throwing any errors with “chef-server-ctl tail
chef-server-webui”. You can also find all the logs at /var/log/chef-server.

It could also be possible that something is wrong with the hostname. See
the docs here: http://docs.opscode.com/install_server.html at the bottom
and see if your hostname checks out. I suspect it’s more likely there is
an error somewhere in the logs, but I’ve been wrong before and likely
will be again.

  • Mark

Ameya Savale mailto:ameya@simplyhired.com
May 5, 2014 at 11:24 PM
Hi Guys,

I’m trying to setup the open source chef-server. I seem to have set
everything up correctly but for some reason when I go to the url of
the server in my browser I only see the nginx default screen. When I
type chef-server-ctl test, all the tests pass. I’ve been searching
online for steps to install the server and all of them only say that
once you run chef-server-ctl reconfigure you should be able to go to
the url in your browser and the chef-server webui should be displayed.
Could someone point me in the right direction please

  • Thanks
    Ameya

#3

Thanks Mark, I will take a look at the logs and see if I can make some
progress

On Mon, May 5, 2014 at 8:45 PM, Mark Mzyk mmzyk@getchef.com wrote:

It should have worked, but it obviously didn’t. Are you seeing any kind of
errors from nginx? You can watch the nginx logs with “chef-server-ctl tail
nginx”. If you need more logs, you can leave off the nginx and just try
"chef-server-ctl tail". You could also watch the webu lgosi and see if it
is throwing any errors with “chef-server-ctl tail chef-server-webui”. You
can also find all the logs at /var/log/chef-server.

It could also be possible that something is wrong with the hostname. See
the docs here: http://docs.opscode.com/install_server.html at the bottom
and see if your hostname checks out. I suspect it’s more likely there is an
error somewhere in the logs, but I’ve been wrong before and likely will be
again.

I’m trying to setup the open source chef-server. I seem to have set
everything up correctly but for some reason when I go to the url of the
server in my browser I only see the nginx default screen. When I type
chef-server-ctl test, all the tests pass. I’ve been searching online for
steps to install the server and all of them only say that once you run
chef-server-ctl reconfigure you should be able to go to the url in your
browser and the chef-server webui should be displayed. Could someone point
me in the right direction please

  • Thanks
    Ameya