Unable to use knife command on Chef workstation

I want to use knife command on chef workstation. But unable to use it now. I deleted my one account using which, I was using knife command but I am getting this error now. I can not understand how to use knife again

ERROR: You authenticated successfully to https: as but user not present in Organisation Response: User not registered in the organisation

I searched a lot on the web but could not come up with a solution

cd C:/chef-repo
knife node list

This is showing error

make sure knife.rb file is having proper details.

client key, validation key and chef server url should be there in the knife.rb

try to delete ssl certs and and install them again and verify them.

may be above inputs may help u.

Certainly sound advice from venkatramreddy! However I hate to ask, but this last part of the error message you sent “user
not present in Organisa… had you logged into your chef-server with admin rights and created an organization? Or were you a part of one, and now can’t connect? This message refers to that you simply are not in the chef-org, deleting an account on the
CHEF-DK side on simply the OS layer Linux or windows wouldn’t remove you from an org, it certainly would mess things up though.

So how about this, what chef-org do you want to connect to: get that first second: do you have access to that org, if not the admin can give you user rights, admin rights, and has to select all the things you can do. You would then get
an email inviting you to the org.

Lastly, it doesn’t hurt to run through the installation again, I believe you can go through a repair mode on windows, I forgot on my centos7 image, if that option isn’t there just re-install the CHEF-DK Workstation, isn’t it on your laptop?
That’s not a big deal to do and then all of your rights to use CHEF-DK will get re-enabled I suspect. If not completely remove/re-install the CHEF-DK

Lots of options thrown around, step through it logically from the CHEF-SERVER itself where the CHEF-ORG you want to get to should be there and you should be a member, verify!


That full message clearly means you are not a user in the CHEF ORG that your KNIFE Logon authenticated user you use, which would be your LAN-ID I suspect, in your organization. This means that the organization seems to exist otherwise you'd get an error to that extent. This means you need to contact the administrator of that Chef Organization so they can give you an invite which authorizes you to logon, you get that message only after they add you to the Chef Org you are trying to go after.

I tried registering the valid user. But it is asking for user.pem file, which i don't have. Please tell me from where to retrieve that. I tried organisation-validator.pem key but it is not working
@almcculloch @venkat5438