Windows 7 workstation for Chef Delivery


#1

I keep getting the error as follows when running command “ssh -l myusername@myorg -p 8989 myserverfqdn”

Permission denied (publickey).

ssh_packet_read: Connection closed


#2

Sorry to hear you are having issues with ssh access on Windows. I have a few things to check that may help out.

Can you check that your ssh key has been added to your account for the delivery server?

click on your username in the upper right hand corner

  • click admin
  • find your username
  • clicking your username should show all the fields including a public ssh key
  • If your ssh key is blank or incorrect, then you should copy your public key and paste it in that field

If you’ve already done that, then can you let me know what version of git you are running on windows? What terminal application are you using as well?

David McCown
Chef Software Engineer


#3

Another thing you could do to help us out is to run the same ssh command with the verbose flag

“ssh -l myusername@myorg -p 8989 myserverfqdn -vvv”

Could you post the output from the above command?

David McCown
Chef Software Engineer


#4

I was able to resolve the issue by uninstalling dk and reinstalling it. And installing git 2.5 all this resolve the issue. Thanks for your response.

Issue resolved


#5

Glad you figured it out! I’ll remember this if someone else has a similar issue.