Berkshelf 4.3.0


#1

Hi,
I’m really excited to announce the release of Berkshelf 4.3.0. This version adds support for the Chef Server universe endpoint, allowing you all to use your chef server to resolve cookbook versions directly. Hosted Chef already supports the universe endpoint, but if you’re running your own chef server, you need to ensure you’re running 12.4.0 or later.
To use your configured chef server, ensure that you’re running 4.3.0, and then simply add:

source :chef_server

to your Berksfile. Berks uses sources in order, so you’ll probably want to have this above the supermarket source.

Thanks,
-Thom


#2

This looks great! I have a question, though: the version of Berkshelf that’s included in the most recent ChefDK release unfortunately does not support this feature; how safe is it to upgrade the ChefDK-installed Berkshelf to 4.3.0 to be able to take advantage of this?


#3

We upgraded the current Chef DK (0.11.2 as of this writing) to use Berkshelf 4.3.0, and it works great. You’ll need to use this method, however:

chef gem install appbundle-updater
appbundle-updater chefdk berkshelf v4.3.0

You may need sudo for the appbundle-updater.

Courtesy of Updating to Test-Kitchen 1.6.0 in a chefdk 0.11.2 or lesser here on the mailing list.


#4

Or install the prerelease chefdk 0.12.


#5

Thanks for the pointer. I’ll give this a shot while I wait for the official v0.12 release of the ChefDK.