Chef 0.8.16 CentOS/RHEL 5 packages


#1

After some testing on a fresh CentOS 5.5 install I’ve pushed updated
Chef packages.

Please let me know of any issues.

Matthew Kent | http://magoazul.com


#2

just want to give a big thanks for all your work on these.

On May 25, 2010, at 11:47 PM, Matthew Kent wrote:

After some testing on a fresh CentOS 5.5 install I’ve pushed updated
Chef packages.

Please let me know of any issues.

Matthew Kent | http://magoazul.com


#3

Me three. Thank you!

On 5/27/10 10:26 AM, Jesse Nelson wrote:

just want to give a big thanks for all your work on these.

On May 25, 2010, at 11:47 PM, Matthew Kent wrote:

After some testing on a fresh CentOS 5.5 install I’ve pushed updated
Chef packages.

Please let me know of any issues.

Matthew Kent | http://magoazul.com


#4

one thing i noticed today.

in the chef-client init script you aren’t passing -P “$pidfile” and
the init script will not restart or stop correctly.

adding this in makes it work perfectly however :slight_smile:

On May 25, 2010, at 11:47 PM, Matthew Kent wrote:

After some testing on a fresh CentOS 5.5 install I’ve pushed updated
Chef packages.

Please let me know of any issues.

Matthew Kent | http://magoazul.com


#5

Jesse Nelson wrote:

one thing i noticed today.

in the chef-client init script you aren’t passing -P “$pidfile” and
the init script will not restart or stop correctly.

adding this in makes it work perfectly however :slight_smile:

It should work from a fresh install (I just tried it) but you’re right -
if you change the pid location in the client.rb or leave it undefined
the init script won’t be able to find it.

I’ve pushed an updated client rpm with your fix.

And thanks guys :slight_smile:

Matthew Kent | http://magoazul.com


#6

On Wed, May 26, 2010 at 1:47 AM, Matthew Kent mkent@magoazul.com wrote:

After some testing on a fresh CentOS 5.5 install I’ve pushed updated Chef
packages.

Please let me know of any issues.

Matthew Kent | http://magoazul.com

I’ve run into some troubles walking through the cookbook (
http://wiki.opscode.com/display/chef/Opscode+Chef+Cookbook) after installing
this on CentOS 5.4. Should it work with 5.4?

Thanks,

-Ian


#7

On Thu, 2010-06-03 at 19:48 -0500, Ian Alderman wrote:

I’ve run into some troubles walking through the cookbook
(http://wiki.opscode.com/display/chef/Opscode+Chef+Cookbook) after
installing this on CentOS 5.4. Should it work with 5.4?

I haven’t tried the opscode Chef cookbook for a while honestly but
having it functional with these packages seems like a good idea.

Mind opening a cookbooks ticket with some failure details and assigning
to me or tossing me the ticket number.


Matthew Kent \ SA \ bravenet.com