Chef-automate configuration error


#1

I am trying to install chef-automate and link to existing chef server. I followed installation guide: https://docs.chef.io/install_chef_automate.html

But when I execute reconfigure, I get below errors. I am able to login to automate UI with admin credentials but my existing org and nodes are not showed up.

I also tried delivery-ctl cleanse followed by delivery-ctl setup, but no luck.

Errors during delivery-ctl reconfigure

  • http_request[refresh the insights index fields] action get[2016-07-14T15:13:40-05:00] ERROR: http_request[refresh the insights index fields] (/opt/delivery/embedded/cookbooks/cache/cookbooks/delivery/resources/elasticsearch_cluster.rb line 57) had an error: Net::HTTPServerException: 404 “Not Found”; ignore_failure is set, continuing

    ================================================================================
    Error executing action get on resource ‘http_request[refresh the insights index fields]’

    Net::HTTPServerException

    404 “Not Found”


#2

I am experiencing this exact same issue. Attempted re-install with no luck.


#3

The reconfigure error shouldn’t be an issue. As you stated ignore_failure is set, so it will be ignored and won’t be related to org or node identification.

Are you installing a fresh automate/delivery server or are you upgrading an existing one?


#4

Yup. I just caught that ignore_failure value. This is a fresh install. I also don’t see any data populated in the dashboard.


#5

I am installing a fresh automate/delivery with existing chef server installation on other VM.


#6

Anil,

In order for Chef Automate to pick up chef data and node data from an
external chef server, both the chef-server and the infrastructure nodes
attached to it need to be configured to send data to Chef Automate.

You’ll need chef-server at version 12.7.0 or greater and chef-client at
version 12.12.14 or greater.

  1. Chef Server Config

There are two pieces of config that needs to be added to your
/etc/opscode/chef-server.rb

data_collector[“root_url”] = the_root_url_of_your_automate_instance +
"/data-collector/v0/"
data_collector[“token”] =
“93a49a4f2482c64126f7b6015e6b0f30284287ee4054ff8807fb63d9cbd1c506”

Where you’d replace the_root_url_of_your_automate_instance with the
delivery_fqdn of your automate instance. The token specified here is the
default token that ships with the product. You can change it by setting
data_collector[“token”] in /etc/delivery/delivery.rb . Note the tokens must
always match across your infrastructure.

Once the config is updated, please run sudo chef-server-ctl reconfigure on
your chef-server. You’ll start to see knife interactions show up in your
Automate instance (cookbook uploads, etc).

  1. Infrastructure nodes

On your infrastructure nodes, please update the /etc/chef/client.rb on
those nodes to include the following

data_collector[“server_url”] = the_root_url_of_your_automate_instance +
"/data-collector/v0/"
data_collector[“token”] =
“93a49a4f2482c64126f7b6015e6b0f30284287ee4054ff8807fb63d9cbd1c506”

Where you’d replace the_root_url_of_your_automate_instance with the
delivery_fqdn of your automate instance.

With those versions and that config, new chef client runs will show up in
automate.

Hope this helps!

Oliver