Chef-Client process blocked

I ran chef-client cookbook on linux machine which schedules every 30 minutes. After that i tried to run chef-client with json as input. I waited for so much time and when i checked processes it showed below information. Still confused why it was blocked for almost an hour. Does any one had this experience.

ps -ef|grep chef
root 3577 1 0 09:21 ? 00:00:00 /opt/chef/embedded/bin/ruby /usr/bin/chef-client -d -c /etc/chef/client.rb -P /var/run/chef/ -i 1800 -s 300
root 3876 3875 0 09:29 ? 00:00:00 sudo /usr/bin/chef-client -j /etc/chef/chef_client_4920.json
root 3877 3876 0 09:29 ? 00:00:02 /opt/chef/embedded/bin/ruby /usr/bin/chef-client -j /etc/chef/chef_client_4920.json
root 3882 3877 0 09:29 ? 00:00:02 chef-client worker: ppid=3877;start=09:29:03;
root 6066 3577 0 09:55 ? 00:00:00 chef-client worker: ppid=3577;start=09:55:17;

I’ve had this happen when internet access failed temporarily. The chef client worker never recovered. Just kill the workers.

My scenario is different as i am working on intranet where it does not have internet connectivity.

That sounds even more likely. Perhaps a recipe is trying to reach out to the internet and can’t. Do a chef-client run manually so that you can see where it hangs. Run in debug mode if you have to.