Chef + Couchdb authentication


#1

I’ve installed chef , which uses couchdb. It worked fine until i’ve secured
couchdb by creating an admin user in couchdb giving and setting
require_valid_user = true in default.ini as written here:
http://guide.couchdb.org/draft/security.html

Now i get a 401 Network error: Connection refused, most probably because of the
newly created user.

Any idea where i can set the new admin username /password for chef to access
the couchdb?


#2

I’ve tried doing what was suggest on the opscode wiki:
http://wiki.opscode.com/display/chef/Chef+Configuration+Settings#ChefConfigurationSettings-couchdb

/etc/chef/server.rb
couchdb_url “http://username:password@localhost:5984

However those settings were unsuccessful after restart of chef-server…

Nick

On Thu, Jul 12, 2012 at 1:30 PM, francesco@beatpick.com wrote:

I’ve installed chef , which uses couchdb. It worked fine until i’ve secured
couchdb by creating an admin user in couchdb giving and setting
require_valid_user = true in default.ini as written here:
http://guide.couchdb.org/draft/security.html

Now i get a 401 Network error: Connection refused, most probably because
of the
newly created user.

Any idea where i can set the new admin username /password for chef to
access
the couchdb?