Chef-server 0.8.6 requires rubygems version >= 1.3.6?


#1

Got the following error when doing the gem install on ubuntu 9.10 server 64
bit:

ERROR: Error installing chef-server:
bundler requires RubyGems version >= 1.3.6
ERROR: Error installing chef-server-webui:
bundler requires RubyGems version >= 1.3.6

Thanks
Dikang


#2

You need to install Merb 1.0.15, rather than merb 1.1.0.

Sent from my iPhone

On Mar 25, 2010, at 3:28 AM, Dikang Gu dikang85@gmail.com wrote:

Got the following error when doing the gem install on ubuntu 9.10
server 64 bit:

ERROR: Error installing chef-server:
bundler requires RubyGems version >= 1.3.6
ERROR: Error installing chef-server-webui:
bundler requires RubyGems version >= 1.3.6

Thanks
Dikang


#3

Adam,

On 25 March 2010 16:45, Adam Jacob adam@opscode.com wrote:

You need to install Merb 1.0.15, rather than merb 1.1.0.

Still, the wiki mentions to install rubygems 1.3.6.

http://wiki.opscode.com/display/chef/Preparing+Debian+and+Ubuntu+for+RubyGems

One might believe that the minimum required version needs to be 1.3.6.
With respect to ticket CHEF-63, I double-checked which version of
rubygems comes with Karmic & Lucid:

http://packages.ubuntu.com/karmic/rubygems
http://packages.ubuntu.com/lucid/rubygems

Both distributions come with rubygems 1.3.5.

Shouldn’t the chef-server installation work with this version?

Ringo


#4

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hello!

On Mar 26, 2010, at 1:22 AM, Ringo De Smet wrote:

Still, the wiki mentions to install rubygems 1.3.6.

http://wiki.opscode.com/display/chef/Preparing+Debian+and+Ubuntu+for+RubyGems

One might believe that the minimum required version needs to be 1.3.6.
With respect to ticket CHEF-63, I double-checked which version of
rubygems comes with Karmic & Lucid:

http://packages.ubuntu.com/karmic/rubygems
http://packages.ubuntu.com/lucid/rubygems

Both distributions come with rubygems 1.3.5.

Shouldn’t the chef-server installation work with this version?

The version of Merb in the Debian/Ubuntu packages is 1.0.12, and
doesn’t use bundler. With Merb version 1.1.0, bundler is an added
dependency, and bundler requires RubyGems 1.3.6.


Opscode, Inc
Joshua Timberman, Senior Solutions Engineer
C: 720.334.RUBY E: joshua@opscode.com

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (Darwin)

iEYEARECAAYFAkus0EUACgkQO97WSdVpzT0nMgCfbwBcDWdlThpYqZJDgdKRjWWb
asEAnAgWaYX28M+spaXplPXoMeLJrBeB
=KaC/
-----END PGP SIGNATURE-----


#5

Ohai,
As Joshua said, the issue is with merb 1.1.0, which we don’t yet
support. Unfortunately, Chef’s gemspec only specifies that it
requires ‘merb’[1] and does not specify any version constraints, so
when you ‘gem install chef-server’ (for example) rubygems will grab
the newest available version of merb. We are tracking the issue as
CHEF-1064[2], for which I have created a patch[3], so I believe the
next release of Chef will not have this problem.

In the meantime, you can fix the issue by installing merb 1.0.15. You
must also uninstall merb 1.1.0 if it is installed.

HTH,
Dan DeLeo

  1. Merb is split up into lots of piecemeal gems. Chef specifically
    requires merb-core, merb-assets, merb-helpers, merb-haml, and
    merb-param-protection, all at version 1.0.15

  2. http://tickets.opscode.com/browse/CHEF-1064

  3. http://github.com/danielsdeleo/chef/tree/CHEF-1064

On Fri, Mar 26, 2010 at 8:18 AM, Joshua Timberman joshua@opscode.com wrote:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hello!

On Mar 26, 2010, at 1:22 AM, Ringo De Smet wrote:

Still, the wiki mentions to install rubygems 1.3.6.

http://wiki.opscode.com/display/chef/Preparing+Debian+and+Ubuntu+for+RubyGems

One might believe that the minimum required version needs to be 1.3.6.
With respect to ticket CHEF-63, I double-checked which version of
rubygems comes with Karmic & Lucid:

http://packages.ubuntu.com/karmic/rubygems
http://packages.ubuntu.com/lucid/rubygems

Both distributions come with rubygems 1.3.5.

Shouldn’t the chef-server installation work with this version?

The version of Merb in the Debian/Ubuntu packages is 1.0.12, and doesn’t use
bundler. With Merb version 1.1.0, bundler is an added dependency, and
bundler requires RubyGems 1.3.6.


Opscode, Inc
Joshua Timberman, Senior Solutions Engineer
C: 720.334.RUBY E: joshua@opscode.com

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (Darwin)

iEYEARECAAYFAkus0EUACgkQO97WSdVpzT0nMgCfbwBcDWdlThpYqZJDgdKRjWWb
asEAnAgWaYX28M+spaXplPXoMeLJrBeB
=KaC/
-----END PGP SIGNATURE-----