Installation problem with ubuntu 8.10/Gem


#1

hi,
I’m trying to install the chef server on Ubuntu 8.10 up-to-date and I
have an error while executing the command:

sudo chef-solo -r http://wiki.opscode.com/download/attachments/1179839/chef-server-install-solo-0.5.2.tar.gz

the error is :

ERROR: package[runit] (/tmp/chef-solo/cookbooks/runit/recipes/default.rb line 27) had an error:
No version specified, and no candidate version available!
/usr/lib/ruby/gems/1.8/gems/chef-0.5.6/lib/chef/provider/package.rb:44:in action_install'/usr/lib/ruby/gems/1.8/gems/chef-0.5.6/lib/chef/runner.rb:87:insend’/usr/lib/ruby/gems/1.8/gems/chef-0.5.6/lib/chef/runner.rb:87:in converge'/usr/lib/ruby/gems/1.8/gems/chef-0.5.6/lib/chef/runner.rb:85:ineach’/usr/lib/ruby/gems/1.8/gems/chef-0.5.6/lib/chef/runner.rb:85:in converge'/usr/lib/ruby/gems/1.8/gems/chef-0.5.6/lib/chef/resource_collection.rb:58:ineach’/usr/lib/ruby/gems/1.8/gems/chef-0.5.6/lib/chef/resource_collection.rb:57:in each'/usr/lib/ruby/gems/1.8/gems/chef-0.5.6/lib/chef/runner.rb:63:inconverge’/usr/lib/ruby/gems/1.8/gems/chef-0.5.6/lib/chef/client.rb:343:in converge'/usr/lib/ruby/gems/1.8/gems/chef-0.5.6/lib/chef/client.rb:96:inrun_solo’/usr/lib/ruby/gems/1.8/gems/chef-0.5.6/bin/chef-solo:94/usr/bin/chef-solo:19:in load'/usr/bin/chef-solo:19 /usr/lib/ruby/gems/1.8/gems/chef-0.5.6/lib/chef/provider/package.rb:44:inaction_install’: No version specified, and no candidate version available! (Chef::Exception::Package)
from /usr/lib/ruby/gems/1.8/gems/chef-0.5.6/lib/chef/runner.rb:87:in send' from /usr/lib/ruby/gems/1.8/gems/chef-0.5.6/lib/chef/runner.rb:87:inconverge’
from /usr/lib/ruby/gems/1.8/gems/chef-0.5.6/lib/chef/runner.rb:85:in each' from /usr/lib/ruby/gems/1.8/gems/chef-0.5.6/lib/chef/runner.rb:85:inconverge’
from /usr/lib/ruby/gems/1.8/gems/chef-0.5.6/lib/chef/resource_collection.rb:58:in each' from /usr/lib/ruby/gems/1.8/gems/chef-0.5.6/lib/chef/resource_collection.rb:57:ineach’
from /usr/lib/ruby/gems/1.8/gems/chef-0.5.6/lib/chef/runner.rb:63:in converge' from /usr/lib/ruby/gems/1.8/gems/chef-0.5.6/lib/chef/client.rb:343:inconverge’
from /usr/lib/ruby/gems/1.8/gems/chef-0.5.6/lib/chef/client.rb:96:in run_solo' from /usr/lib/ruby/gems/1.8/gems/chef-0.5.6/bin/chef-solo:94 from /usr/bin/chef-solo:19:inload’
from /usr/bin/chef-solo:19

Can you please explain me what is wrong ?

Mathieu Negre
Mimesis Republic
80 Rue des Haies
75020 Paris
Tel 01.55 25.76.11
Gsm 06.22.51.78.13


#2

You’ll need to enable universe and multiverse - I don’t recall which
Runit is in.

Regards,

AJ

On 9/04/2009, at 9:54 PM, Mathieu Negre <mathieu.negre@mimesis-republic.com

wrote:

hi,
I’m trying to install the chef server on Ubuntu 8.10 up-to-date and I
have an error while executing the command:

sudo chef-solo -r http://wiki.opscode.com/download/attachments/1179839/chef-server-install-solo-0.5.2.tar.gz

the error is :

ERROR: package[runit] (/tmp/chef-solo/cookbooks/runit/recipes/
default.rb line 27) had an error:
No version specified, and no candidate version available!
/usr/lib/ruby/gems/1.8/gems/chef-0.5.6/lib/chef/provider/package.rb:
44:in action_install'/usr/lib/ruby/gems/1.8/gems/chef-0.5.6/lib/ chef/runner.rb:87:insend’/usr/lib/ruby/gems/1.8/gems/chef-0.5.6/
lib/chef/runner.rb:87:in converge'/usr/lib/ruby/gems/1.8/gems/ chef-0.5.6/lib/chef/runner.rb:85:ineach’/usr/lib/ruby/gems/1.8/
gems/chef-0.5.6/lib/chef/runner.rb:85:in converge'/usr/lib/ruby/ gems/1.8/gems/chef-0.5.6/lib/chef/resource_collection.rb:58:ineach’/usr/lib/ruby/gems/1.8/gems/chef-0.5.6/lib/chef/
resource_collection.rb:57:in each'/usr/lib/ruby/gems/1.8/gems/ chef-0.5.6/lib/chef/runner.rb:63:inconverge’/usr/lib/ruby/gems/
1.8/gems/chef-0.5.6/lib/chef/client.rb:343:in converge'/usr/lib/ ruby/gems/1.8/gems/chef-0.5.6/lib/chef/client.rb:96:inrun_solo’/
usr/lib/ruby/gems/1.8/gems/chef-0.5.6/bin/chef-solo:94/usr/bin/chef-
solo:19:in load'/usr/bin/chef-solo:19 /usr/lib/ruby/gems/1.8/gems/chef-0.5.6/lib/chef/provider/package.rb: 44:inaction_install’: No version specified, and no candidate
version available! (Chef::Exception::Package)
from /usr/lib/ruby/gems/1.8/gems/chef-0.5.6/lib/chef/runner.rb:
87:in send' from /usr/lib/ruby/gems/1.8/gems/chef-0.5.6/lib/chef/runner.rb: 87:inconverge’
from /usr/lib/ruby/gems/1.8/gems/chef-0.5.6/lib/chef/runner.rb:
85:in each' from /usr/lib/ruby/gems/1.8/gems/chef-0.5.6/lib/chef/runner.rb: 85:inconverge’
from /usr/lib/ruby/gems/1.8/gems/chef-0.5.6/lib/chef/
resource_collection.rb:58:in each' from /usr/lib/ruby/gems/1.8/gems/chef-0.5.6/lib/chef/ resource_collection.rb:57:ineach’
from /usr/lib/ruby/gems/1.8/gems/chef-0.5.6/lib/chef/runner.rb:
63:in converge' from /usr/lib/ruby/gems/1.8/gems/chef-0.5.6/lib/chef/client.rb: 343:inconverge’
from /usr/lib/ruby/gems/1.8/gems/chef-0.5.6/lib/chef/client.rb:
96:in run_solo' from /usr/lib/ruby/gems/1.8/gems/chef-0.5.6/bin/chef-solo:94 from /usr/bin/chef-solo:19:inload’
from /usr/bin/chef-solo:19

Can you please explain me what is wrong ?

Mathieu Negre
Mimesis Republic
80 Rue des Haies
75020 Paris
Tel 01.55 25.76.11
Gsm 06.22.51.78.13


#3

On 9/04/2009, at 9:54 PM, Mathieu Negre wrote:

hi,
I’m trying to install the chef server on Ubuntu 8.10 up-to-date and I
have an error while executing the command:

sudo chef-solo -r http://wiki.opscode.com/download/attachments/1179839/chef-server-install-solo-0.5.2.tar.gz

the error is :

ERROR: package[runit] (/tmp/chef-solo/cookbooks/runit/recipes/
default.rb line 27) had an error:
No version specified, and no candidate version available!
Can you please explain me what is wrong ?

Sorry was on iPhone earlier and couldn’t c/p this:
https://launchpad.net/ubuntu/intrepid/+source/runit/2.0.0-1ubuntu1

2.0.0-1ubuntu1
PUBLISHED: Intrepid pocket Release in component universe and section
admin

Have you got Universe enabled?

Regards,

AJ


#4

Hi !

Have you got Universe enabled?

Yes multiverse is enabled. running sudo apt-get install runit install
the 2.0.0 version of runit.

Regards,

AJ


Mathieu Negre
Mimesis Republic
80 Rue des Haies
75020 Paris
Tel 01.55 25.76.11
Gsm 06.22.51.78.13


#5

Hi,

I think I had the same problem, I was install the base ubuntu system with
spanish laguage, you installed in french?

Hope this help. I was crazzy for three days with this.


José Luis Gordo Romero
SysAdmin
Tractis - Online contracts you can enforce
http://www.tractis.com

2009/4/10 Mathieu Negre mathieu.negre@mimesis-republic.com

Hi !

Have you got Universe enabled?

Yes multiverse is enabled. running sudo apt-get install runit install
the 2.0.0 version of runit.

Regards,

AJ


Mathieu Negre
Mimesis Republic
80 Rue des Haies
75020 Paris
Tel 01.55 25.76.11
Gsm 06.22.51.78.13


#6

Could you give us debug logs? (chef-client -l debug)

Regards,

AJ

On 10/04/2009, at 9:51 PM, José Luis Gordo Romero wrote:

Hi,

I think I had the same problem, I was install the base ubuntu system
with spanish laguage, you installed in french?

Hope this help. I was crazzy for three days with this.


José Luis Gordo Romero
SysAdmin
Tractis - Online contracts you can enforce
http://www.tractis.com

2009/4/10 Mathieu Negre mathieu.negre@mimesis-republic.com
Hi !

Have you got Universe enabled?

Yes multiverse is enabled. running sudo apt-get install runit install
the 2.0.0 version of runit.

Regards,

AJ


Mathieu Negre
Mimesis Republic
80 Rue des Haies
75020 Paris
Tel 01.55 25.76.11
Gsm 06.22.51.78.13


#7

Yes my base system was installed in french.
So I tried with a brand new machine full english installed, and it works
well. (for the chef-solo server)

Le vendredi 10 avril 2009 à 11:51 +0200, José Luis Gordo Romero a
écrit :

Hi,

I think I had the same problem, I was install the base ubuntu system
with spanish laguage, you installed in french?

Hope this help. I was crazzy for three days with this.


José Luis Gordo Romero
SysAdmin
Tractis - Online contracts you can enforce
http://www.tractis.com

2009/4/10 Mathieu Negre mathieu.negre@mimesis-republic.com
Hi !

    > Have you got Universe enabled?
    
    
    Yes multiverse is enabled. running sudo apt-get install runit
    install
    the 2.0.0 version of runit.
    
    
    
    >
    > Regards,
    >
    >
    > AJ
    
    --
    --
    Mathieu Negre
    Mimesis Republic
    80 Rue des Haies
    75020 Paris
    Tel 01.55 25.76.11
    Gsm 06.22.51.78.13

Mathieu Negre
Mimesis Republic
80 Rue des Haies
75020 Paris
Tel 01.55 25.76.11
Gsm 06.22.51.78.13


#8

This is a known issue, and we are aware of a fix (run the apt commands
with LANG=en_us or similar) but I don’t believe there is a ticket open

  • mind opening one?

Regards,

AJ

On 10/04/2009, at 10:29 PM, Mathieu Negre wrote:

Yes my base system was installed in french.
So I tried with a brand new machine full english installed, and it
works
well. (for the chef-solo server)

Le vendredi 10 avril 2009 à 11:51 +0200, José Luis Gordo Romero a
écrit :

Hi,

I think I had the same problem, I was install the base ubuntu system
with spanish laguage, you installed in french?

Hope this help. I was crazzy for three days with this.


José Luis Gordo Romero
SysAdmin
Tractis - Online contracts you can enforce
http://www.tractis.com

2009/4/10 Mathieu Negre mathieu.negre@mimesis-republic.com
Hi !

Have you got Universe enabled?

   Yes multiverse is enabled. running sudo apt-get install runit
   install
   the 2.0.0 version of runit.

Regards,

AJ

   --
   --
   Mathieu Negre
   Mimesis Republic
   80 Rue des Haies
   75020 Paris
   Tel 01.55 25.76.11
   Gsm 06.22.51.78.13

Mathieu Negre
Mimesis Republic
80 Rue des Haies
75020 Paris
Tel 01.55 25.76.11
Gsm 06.22.51.78.13


#9

this is CHEF-190 …

On Fri, Apr 10, 2009 at 6:45 AM, AJ Christensen aj@junglist.gen.nz wrote:

This is a known issue, and we are aware of a fix (run the apt commands with
LANG=en_us or similar) but I don’t believe there is a ticket open - mind
opening one?

Regards,

AJ

On 10/04/2009, at 10:29 PM, Mathieu Negre wrote:

Yes my base system was installed in french.
So I tried with a brand new machine full english installed, and it works
well. (for the chef-solo server)

Le vendredi 10 avril 2009 à 11:51 +0200, José Luis Gordo Romero a
écrit :

Hi,

I think I had the same problem, I was install the base ubuntu system
with spanish laguage, you installed in french?

Hope this help. I was crazzy for three days with this.


José Luis Gordo Romero
SysAdmin
Tractis - Online contracts you can enforce
http://www.tractis.com

2009/4/10 Mathieu Negre mathieu.negre@mimesis-republic.com
Hi !

Have you got Universe enabled?

  Yes multiverse is enabled. running sudo apt-get install runit
  install
  the 2.0.0 version of runit.

Regards,

AJ

  --
  --
  Mathieu Negre
  Mimesis Republic
  80 Rue des Haies
  75020 Paris
  Tel 01.55 25.76.11
  Gsm 06.22.51.78.13

Mathieu Negre
Mimesis Republic
80 Rue des Haies
75020 Paris
Tel 01.55 25.76.11
Gsm 06.22.51.78.13


#10

Oh, my bad.

=D

On 10/04/2009, at 10:59 PM, Thom May wrote:

this is CHEF-190 …

On Fri, Apr 10, 2009 at 6:45 AM, AJ Christensen aj@junglist.gen.nz
wrote:

This is a known issue, and we are aware of a fix (run the apt
commands with
LANG=en_us or similar) but I don’t believe there is a ticket open -
mind
opening one?

Regards,

AJ

On 10/04/2009, at 10:29 PM, Mathieu Negre wrote:

Yes my base system was installed in french.
So I tried with a brand new machine full english installed, and it
works
well. (for the chef-solo server)

Le vendredi 10 avril 2009 à 11:51 +0200, José Luis Gordo Romero a
écrit :

Hi,

I think I had the same problem, I was install the base ubuntu
system
with spanish laguage, you installed in french?

Hope this help. I was crazzy for three days with this.


José Luis Gordo Romero
SysAdmin
Tractis - Online contracts you can enforce
http://www.tractis.com

2009/4/10 Mathieu Negre mathieu.negre@mimesis-republic.com
Hi !

Have you got Universe enabled?

  Yes multiverse is enabled. running sudo apt-get install runit
  install
  the 2.0.0 version of runit.

Regards,

AJ

  --
  --
  Mathieu Negre
  Mimesis Republic
  80 Rue des Haies
  75020 Paris
  Tel 01.55 25.76.11
  Gsm 06.22.51.78.13

Mathieu Negre
Mimesis Republic
80 Rue des Haies
75020 Paris
Tel 01.55 25.76.11
Gsm 06.22.51.78.13


#11

I’m working on this one. The workaroundfor now is as AJ says. Run chef-
client or chef-solo like this:

% chef-client LANG=en_US

Joshua Sierles

On Apr 10, 2009, at 12:59 PM, Thom May wrote:

this is CHEF-190 …

On Fri, Apr 10, 2009 at 6:45 AM, AJ Christensen aj@junglist.gen.nz
wrote:

This is a known issue, and we are aware of a fix (run the apt
commands with
LANG=en_us or similar) but I don’t believe there is a ticket open -
mind
opening one?

Regards,

AJ

On 10/04/2009, at 10:29 PM, Mathieu Negre wrote:

Yes my base system was installed in french.
So I tried with a brand new machine full english installed, and it
works
well. (for the chef-solo server)

Le vendredi 10 avril 2009 à 11:51 +0200, José Luis Gordo Romero a
écrit :

Hi,

I think I had the same problem, I was install the base ubuntu
system
with spanish laguage, you installed in french?

Hope this help. I was crazzy for three days with this.


José Luis Gordo Romero
SysAdmin
Tractis - Online contracts you can enforce
http://www.tractis.com

2009/4/10 Mathieu Negre mathieu.negre@mimesis-republic.com
Hi !

Have you got Universe enabled?

  Yes multiverse is enabled. running sudo apt-get install runit
  install
  the 2.0.0 version of runit.

Regards,

AJ

  --
  --
  Mathieu Negre
  Mimesis Republic
  80 Rue des Haies
  75020 Paris
  Tel 01.55 25.76.11
  Gsm 06.22.51.78.13

Mathieu Negre
Mimesis Republic
80 Rue des Haies
75020 Paris
Tel 01.55 25.76.11
Gsm 06.22.51.78.13