Chef server problem


#1

root@li105-182:~# chef-solo -c ~/solo.rb -j ~/chef.json -r
http://s3.amazonaws.com/chef-solo/bootstrap-latest.tar.gz
[Tue, 11 Aug 2009 21:25:17 +0000] INFO: Starting Chef Solo Run
[Tue, 11 Aug 2009 21:25:18 +0000] ERROR: package[runit]
(/tmp/chef-solo/cookbooks/runit/recipes/default.rb line 32) had an
error:
No version specified, and no candidate version available!
/usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/provider/package.rb:50:in
action_install'/usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/runner.rb:87:insend’/usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/runner.rb:87:in
converge'/usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/runner.rb:85:ineach’/usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/runner.rb:85:in
converge'/usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/resource_collection.rb:58:ineach’/usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/resource_collection.rb:57:in
each'/usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/runner.rb:63:inconverge’/usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/client.rb:373:in
converge'/usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/client.rb:101:inrun_solo’/usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/application/solo.rb:122:in
run_application'/usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/application.rb:57:inrun’/usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/bin/chef-solo:26/usr/local/bin/chef-solo:19:in
load'/usr/local/bin/chef-solo:19 /usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/provider/package.rb:50:inaction_install’: No version specified, and no candidate version
available! (Chef::Exceptions::Package)
from /usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/runner.rb:87:in
send' from /usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/runner.rb:87:inconverge’
from /usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/runner.rb:85:in
each' from /usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/runner.rb:85:inconverge’
from /usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/resource_collection.rb:58:in
each' from /usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/resource_collection.rb:57:ineach’
from /usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/runner.rb:63:in
converge' from /usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/client.rb:373:inconverge’
from /usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/client.rb:101:in
run_solo' from /usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/application/solo.rb:122:inrun_application’
from /usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/application.rb:57:in
run' from /usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/bin/chef-solo:26 from /usr/local/bin/chef-solo:19:inload’
from /usr/local/bin/chef-solo:19


Joe Van Dyk
http://fixieconsulting.com


#2

Problem was that the universe repository wasn’t enabled in
/etc/apt/sources.list. Thanks jtimberman.

On Tue, Aug 11, 2009 at 2:25 PM, Joe Van Dykjoe@fixieconsulting.com wrote:

root@li105-182:~# chef-solo -c ~/solo.rb -j ~/chef.json -r
http://s3.amazonaws.com/chef-solo/bootstrap-latest.tar.gz
[Tue, 11 Aug 2009 21:25:17 +0000] INFO: Starting Chef Solo Run
[Tue, 11 Aug 2009 21:25:18 +0000] ERROR: package[runit]
(/tmp/chef-solo/cookbooks/runit/recipes/default.rb line 32) had an
error:
No version specified, and no candidate version available!
/usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/provider/package.rb:50:in
action_install'/usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/runner.rb:87:insend’/usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/runner.rb:87:in
converge'/usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/runner.rb:85:ineach’/usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/runner.rb:85:in
converge'/usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/resource_collection.rb:58:ineach’/usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/resource_collection.rb:57:in
each'/usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/runner.rb:63:inconverge’/usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/client.rb:373:in
converge'/usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/client.rb:101:inrun_solo’/usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/application/solo.rb:122:in
run_application'/usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/application.rb:57:inrun’/usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/bin/chef-solo:26/usr/local/bin/chef-solo:19:in
load'/usr/local/bin/chef-solo:19 /usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/provider/package.rb:50:inaction_install’: No version specified, and no candidate version
available! (Chef::Exceptions::Package)
from /usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/runner.rb:87:in
send' from /usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/runner.rb:87:inconverge’
from /usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/runner.rb:85:in
each' from /usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/runner.rb:85:inconverge’
from /usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/resource_collection.rb:58:in
each' from /usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/resource_collection.rb:57:ineach’
from /usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/runner.rb:63:in
converge' from /usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/client.rb:373:inconverge’
from /usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/client.rb:101:in
run_solo' from /usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/application/solo.rb:122:inrun_application’
from /usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/lib/chef/application.rb:57:in
run' from /usr/local/lib/ruby/gems/1.8/gems/chef-0.7.4/bin/chef-solo:26 from /usr/local/bin/chef-solo:19:inload’
from /usr/local/bin/chef-solo:19


Joe Van Dyk
http://fixieconsulting.com


Joe Van Dyk
http://fixieconsulting.com