Chef-Server Ubuntu 15.10

Is it safe to run Chef server on Ubuntu 15.10? Have anyone tried?

If not, that when you plan to support it?

Yep! Works fine. I’d be sure to install from though.

Yup. I run chef on wily, along side the systemd cookbook. So far no issues
specific to 15.10

@jjasghar and @Ranjib thank you for your replies. Have you tried to install push jobs and/or reports? As when try to re-configure (sudo opscode-push-jobs-server-ctl reconfigure) one of these I get following error:


  • execute[initctl status private-chef-runsvdir] action run
    Error executing action run on resource 'execute[initctl status private-chef-runsvdir]'


No such file or directory - initctl status private-chef-runsvdir

Resource Declaration:

In /opt/opscode-push-jobs-server/embedded/cookbooks/enterprise/recipes/runit_upstart.rb

28: execute "initctl status private-chef-runsvdir" do
29: retries 30
30: end

Compiled Resource:

Declared in /opt/opscode-push-jobs-server/embedded/cookbooks/enterprise/recipes/runit_upstart.rb:28:in `from_file'

execute("initctl status private-chef-runsvdir") do
action "run"
retries 0
retry_delay 2
guard_interpreter :default
command "initctl status private-chef-runsvdir"
backup 5
returns 0
cookbook_name :enterprise
recipe_name "runit_upstart"

Running handlers:
[2016-04-03T17:17:15+00:00] ERROR: Running exception handlers
Running handlers complete

[2016-04-03T17:17:15+00:00] ERROR: Exception handlers complete
[2016-04-03T17:17:15+00:00] FATAL: Stacktrace dumped to /opt/opscode-push-jobs-server/embedded/cookbooks/cache/chef-stacktrace.out
Chef Client failed. 5 resources updated in 62.258658862 seconds
[2016-04-03T17:17:15+00:00] ERROR: execute[initctl status private-chef-runsvdir] (enterprise::runit_upstart line 28) had an error: Errno::ENOENT: No such file or directory - initctl status private-chef-runsvdir
[2016-04-03T17:17:15+00:00] FATAL: Chef::Exceptions::ChildConvergeError: Chef run process exited unsuccessfully (exit code 1)

Sequence of commands I run:
sudo chef-server-ctl install opscode-push-jobs-server sudo chef-server-ctl reconfigure sudo opscode-push-jobs-server-ctl reconfigure

I think it due initctl which is upstart which was removed in 15.04? Have you faced same problem and how you overcome/workaround it?