Chef timeout


#1

I’m writing a recipe that involves installing some packages with yum. One of
these packages takes a long time installing, and during the installation of
this package, Chef times out with the message “ERROR: yum -d0 -e0 -y install
exceeded timeout 900”

I have browsed and searched the documentation, but have not found any reference
to how to increase this timeout. Can someone shed light on this?


#2

Not sure if this is in the documentation anywhere, but the provider will check if Chef::Config[:yum_timeout] is set, and presumably honor that timeout value if it exists in your client.rb file. Let me know if this does it for you.

On September 26, 2013 at 1:19:20 AM, nilsga@gmail.com (nilsga@gmail.com) wrote:

I’m writing a recipe that involves installing some packages with yum. One of
these packages takes a long time installing, and during the installation of
this package, Chef times out with the message “ERROR: yum -d0 -e0 -y install
exceeded timeout 900”

I have browsed and searched the documentation, but have not found any reference
to how to increase this timeout. Can someone shed light on this?


#3

I’m using Vagrant with chec-solo in this setup. What is the equivalent of
client.rb in this case? Can it be put somewhere in the Vagrantfile?

On Thu, Sep 26, 2013 at 2:12 PM, Tim Green tgreen@opscode.com wrote:

Not sure if this is in the documentation anywhere, but the provider will
check if Chef::Config[:yum_timeout] is set, and presumably honor that
timeout value if it exists in your client.rb file. Let me know if this
does it for you.

On September 26, 2013 at 1:19:20 AM, nilsga@gmail.com (nilsga@gmail.com//nilsga@gmail.com)
wrote:

I’m writing a recipe that involves installing some packages with yum. One
of
these packages takes a long time installing, and during the installation
of
this package, Chef times out with the message “ERROR: yum -d0 -e0 -y
install
exceeded timeout 900”

I have browsed and searched the documentation, but have not found any
reference
to how to increase this timeout. Can someone shed light on this?


#4

chef-solo uses solo.rb with the same format as client.rb. For Chef
alone, this defaults to /etc/chef/solo.rb. Vagrant creates this file
on the instance, and looking at the source there doesn’t appear to be
a way to add any additional options using Vagrant directly.

Try putting it in your recipe before you use yum_package.

Chef::Config[:yum_timeout] = 1800

Bryan

On Thu, Sep 26, 2013 at 9:03 AM, Nils-Helge Garli Hegvik
nilsga@gmail.com wrote:

I’m using Vagrant with chec-solo in this setup. What is the equivalent of
client.rb in this case? Can it be put somewhere in the Vagrantfile?

On Thu, Sep 26, 2013 at 2:12 PM, Tim Green tgreen@opscode.com wrote:

Not sure if this is in the documentation anywhere, but the provider will
check if Chef::Config[:yum_timeout] is set, and presumably honor that
timeout value if it exists in your client.rb file. Let me know if this does
it for you.

On September 26, 2013 at 1:19:20 AM, nilsga@gmail.com (nilsga@gmail.com)
wrote:

I’m writing a recipe that involves installing some packages with yum. One
of
these packages takes a long time installing, and during the installation
of
this package, Chef times out with the message “ERROR: yum -d0 -e0 -y
install
exceeded timeout 900”

I have browsed and searched the documentation, but have not found any
reference
to how to increase this timeout. Can someone shed light on this?