Timeouts with bash


#1

Hi,

How do I increase the timeout for a bash script? I set the timeout to 6000
yet I get FAIL - bootstrap timeout exceeded: seconds=> 2500

bash “install_frontend” do
cwd "#{BASE_DIR}/etl-rails"
user "#{USER}"
timeout 6000
code <<-EOH
bundle install
./bin/rake db:migrate RAILS_ENV=#{node.environment}
sudo chmod 777
/usr/local/lib/ruby/gems/2.1.0/gems/designmodo-flatuipro-rails-1.3.2.0.branch/
rails g flatuipro:install “#{BASE_DIR}/Flat UI PSD & HTML - Developers
License/“
rm app/assets/stylesheets/application.css
chown -R #{USER}:#{USER} #{BASE_DIR}/etl-rails/
#rails s
touch #{Chef::Config[:file_cache_path]}/frontend.lock
EOH
not_if {File.exists?(”#{Chef::Config[:file_cache_path]}/frontend.lock”)}
end

None ---- 2315.58032513 — [54.237.202.145] out: -
0014-Fix-for-bug-436589.patch
None ---- 2315.58040118 — [54.237.202.145] out: -
0015-Fix-mkdir-for-mingw.patch
None ---- 2315.58053112 — [54.237.202.145] out:


   None ---- 2315.58064914 --- [54.237.202.145] out: IMPORTANT!

Nokogiri builds and uses a packaged version of libxslt.
None ---- 2315.58068705 — [54.237.202.145] out:
None ---- 2315.5808022 — [54.237.202.145] out: If this is a
concern for you and you want to use the system library
None ---- 2315.58091617 — [54.237.202.145] out: instead, abort
this installation process and reinstall nokogiri as
None ---- 2315.58096313 — [54.237.202.145] out: follows:
None ---- 2315.58100009 — [54.237.202.145] out:
None ---- 2315.58182907 — [54.237.202.145] out: gem install
nokogiri – --use-system-libraries
None ---- 2315.5821352 — [54.237.202.145] out:
None ---- 2315.58249402 — [54.237.202.145] out: If you are using
Bundler, tell it to use the option:
None ---- 2315.58279109 — [54.237.202.145] out:
None ---- 2315.5831511 — [54.237.202.145] out: bundle config
build.nokogiri --use-system-libraries
None ---- 2315.58346701 — [54.237.202.145] out: bundle install
None ---- 2315.583601 — [54.237.202.145] out:


   None ---- 2502.37049603 --- [54.237.202.145] out:
   FAIL - bootstrap timeout exceeded: seconds=> 2500