Command Execution failing from Chef cookbook


#1

Hi Friends,

We have a cookbook with resources and one of the resource ahving execute a windows command with some parameters. When i run the same directly on server the command running fine and giving results as expected. But the same command i used in execute resource and got failing with fatal error and unable to initialised some of services (command will initilise services).

Any one faced same issue? let me know any way to resolve this issue?

thanks
Bala


#2

Can you be a bit more specific? What type of command are you attempting to execute? How are you passing the parameters? Which Chef resource type are you using?


#3

I am using a bat file execution from execute resources. The .bat file is having below details as below:
install.exe sielntinstall.py --boostrapfile

the same command when i executed directly on server (AWS instance created by chef) its running fine. but failing from chef end.
And when i run the same cookbook from local (on AWS which created by chef code) using chef-client -z -o then also running fine.

thanks Bala