Erchef error when heartbeat with postgres


#1

Hi,

I am using pgpool-II and postgres instead of the default postgres.
But I got the following errors:

tail /var/log/chef-server/erchef/erchef.log
2014-10-27_07:49:23.61875 [error] gen_fsm <0.25100.138> in state ready
terminated with reason: sock_closed
2014-10-27_07:49:23.61906 [error] CRASH REPORT Process <0.25100.138> with 1
neighbours exited with reason: sock_closed in gen_fsm:terminate/7 line 611
2014-10-27_07:49:23.62537 [error] Supervisor pooler_sqerl_member_sup had child
sqerl_client started with {sqerl_client,start_link,undefined} at <0.25098.138>
exit with reason sock_closed in context child_terminated

tail /var/log/pgpool.log
014-10-25 02:01:10 ERROR: pid 17982: pool_read: read failed (Connection reset
by peer)
2014-10-25 02:01:10 LOG: pid 17982: ProcessFrontendResponse: failed to read
kind from frontend. frontend abnormally exited

However I still can use all knife commands. I think the error comes from
heartbeat between chef-server and pgpool.

I tried to restart and reconfigure chef-server sometimes, but still got these
errors.
Is there anyone who got the same error before?