Error attempting to upload a cookbook to the community site


#1

Anyone have an idea of what could cause knife to blow up like this when trying to upload a cookbook to the community site.

Ubuntu 12.04. Ruby 1.8.7

smitht@sops02:~/chef-repo$ sudo knife cookbook site share kafka “Operating Systems & Virtualization” -V
INFO: Validating ruby files
INFO: Validating templates
INFO: Syntax OK
Generating metadata for kafka from /tmp/chef-kafka-build20121009-3570-1rvglf1-0/kafka/metadata.rb
Making tarball kafka.tgz
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:31: warning: already initialized constant VERSION
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:94: warning: already initialized constant ERASE_LINE_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:95: warning: already initialized constant ERASE_CHAR_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:96: warning: already initialized constant CLEAR_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:97: warning: already initialized constant RESET_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:98: warning: already initialized constant BOLD_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:101: warning: already initialized constant DARK_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:102: warning: already initialized constant UNDERLINE_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:103: warning: already initialized constant UNDERSCORE_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:104: warning: already initialized constant BLINK_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:105: warning: already initialized constant REVERSE_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:106: warning: already initialized constant CONCEALED_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:108: warning: already initialized constant STYLES
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:111: warning: already initialized constant BLACK_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:112: warning: already initialized constant RED_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:113: warning: already initialized constant GREEN_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:114: warning: already initialized constant BLUE_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:115: warning: already initialized constant YELLOW_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:116: warning: already initialized constant MAGENTA_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:117: warning: already initialized constant CYAN_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:119: warning: already initialized constant WHITE_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:121: warning: already initialized constant GRAY_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:124: warning: already initialized constant NONE_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:126: warning: already initialized constant BASIC_COLORS
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:132: warning: already initialized constant BRIGHT_BLACK_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:132: warning: already initialized constant BRIGHT_RED_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:132: warning: already initialized constant BRIGHT_GREEN_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:132: warning: already initialized constant BRIGHT_YELLOW_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:132: warning: already initialized constant BRIGHT_BLUE_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:132: warning: already initialized constant BRIGHT_MAGENTA_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:132: warning: already initialized constant BRIGHT_CYAN_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:132: warning: already initialized constant BRIGHT_WHITE_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:132: warning: already initialized constant BRIGHT_GRAY_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:132: warning: already initialized constant BRIGHT_NONE_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:134: warning: already initialized constant COLORS
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:137: warning: already initialized constant BLACK
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:138: warning: already initialized constant ON_BLACK_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:139: warning: already initialized constant ON_BLACK
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:137: warning: already initialized constant RED
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:138: warning: already initialized constant ON_RED_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:139: warning: already initialized constant ON_RED
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:137: warning: already initialized constant GREEN
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:138: warning: already initialized constant ON_GREEN_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:139: warning: already initialized constant ON_GREEN
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:137: warning: already initialized constant YELLOW
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:138: warning: already initialized constant ON_YELLOW_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:139: warning: already initialized constant ON_YELLOW
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:137: warning: already initialized constant BLUE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:138: warning: already initialized constant ON_BLUE_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:139: warning: already initialized constant ON_BLUE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:137: warning: already initialized constant MAGENTA
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:138: warning: already initialized constant ON_MAGENTA_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:139: warning: already initialized constant ON_MAGENTA
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:137: warning: already initialized constant CYAN
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:138: warning: already initialized constant ON_CYAN_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:139: warning: already initialized constant ON_CYAN
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:137: warning: already initialized constant WHITE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:138: warning: already initialized constant ON_WHITE_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:139: warning: already initialized constant ON_WHITE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:137: warning: already initialized constant GRAY
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:138: warning: already initialized constant ON_GRAY_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:139: warning: already initialized constant ON_GRAY
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:137: warning: already initialized constant NONE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:138: warning: already initialized constant ON_NONE_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:139: warning: already initialized constant ON_NONE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:137: warning: already initialized constant BRIGHT_BLACK
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:138: warning: already initialized constant ON_BRIGHT_BLACK_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:139: warning: already initialized constant ON_BRIGHT_BLACK
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:137: warning: already initialized constant BRIGHT_RED
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:138: warning: already initialized constant ON_BRIGHT_RED_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:139: warning: already initialized constant ON_BRIGHT_RED
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:137: warning: already initialized constant BRIGHT_GREEN
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:138: warning: already initialized constant ON_BRIGHT_GREEN_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:139: warning: already initialized constant ON_BRIGHT_GREEN
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:137: warning: already initialized constant BRIGHT_YELLOW
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:138: warning: already initialized constant ON_BRIGHT_YELLOW_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:139: warning: already initialized constant ON_BRIGHT_YELLOW
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:137: warning: already initialized constant BRIGHT_BLUE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:138: warning: already initialized constant ON_BRIGHT_BLUE_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:139: warning: already initialized constant ON_BRIGHT_BLUE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:137: warning: already initialized constant BRIGHT_MAGENTA
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:138: warning: already initialized constant ON_BRIGHT_MAGENTA_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:139: warning: already initialized constant ON_BRIGHT_MAGENTA
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:137: warning: already initialized constant BRIGHT_CYAN
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:138: warning: already initialized constant ON_BRIGHT_CYAN_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:139: warning: already initialized constant ON_BRIGHT_CYAN
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:137: warning: already initialized constant BRIGHT_WHITE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:138: warning: already initialized constant ON_BRIGHT_WHITE_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:139: warning: already initialized constant ON_BRIGHT_WHITE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:137: warning: already initialized constant BRIGHT_GRAY
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:138: warning: already initialized constant ON_BRIGHT_GRAY_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:139: warning: already initialized constant ON_BRIGHT_GRAY
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:137: warning: already initialized constant BRIGHT_NONE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:138: warning: already initialized constant ON_BRIGHT_NONE_STYLE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:139: warning: already initialized constant ON_BRIGHT_NONE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:144: warning: already initialized constant CLEAR
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:144: warning: already initialized constant RESET
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:144: warning: already initialized constant BOLD
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:144: warning: already initialized constant DARK
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:144: warning: already initialized constant UNDERLINE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:144: warning: already initialized constant UNDERSCORE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:144: warning: already initialized constant BLINK
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:144: warning: already initialized constant REVERSE
/var/lib/gems/1.8/gems/highline-1.6.15/lib/highline.rb:144: warning: already initialized constant CONCEALED
ERROR: Error uploading cookbook kafka to the Opscode Cookbook Site: Is a directory - /tmp/chef-kafka-build20121009-3570-1rvglf1-0. Set log level to debug (-l debug) for more information.


#2

On Mon, Oct 8, 2012 at 11:07 PM, Tim Smith Tim.Smith@webtrends.com wrote:

Anyone have an idea of what could cause knife to blow up like this when
trying to upload a cookbook to the community site.

Ubuntu 12.04. Ruby 1.8.7

How are your libraries installed, system packages or rubygems? Maybe
you’ve got one of both or in the case of using rubygems could use a
’gem cleanup highline’?

Bryan