Error running chef with azure


#1

Hi guys,

I’m new with Chef and I’m trying to create a Virtual Machine on Azure and also run recipes on it.

Here’s the full command I’m trying:

knife azure server create --azure-dns-name ‘knifeth10’ --azure-source-image “a699494373c04fc0bc8f2bb1389d6106__Windows-Server-2012-Datacenter-201408.01-en.us-127GB.vhd” --azure-service-location “East US” -P “Pizza1234” -z Small -x “thiago” --tcp-endpoints ‘3389:3389,5985:5985’ -r "role[iis] " -VV

It’s working for the creating of the virtual machine. However, the run list is not working. I’m stuck with this error and I don’t know what to do, I appreciate any help. Here’s the full log:

C:\Users\thiago>knife azure server create --azure-source-image "a699494373c04fc0

bc8f2bb1389d6106__Windows-Server-2012-Datacenter-201408.01-en.us-127GB.vhd" --az

ure-service-location “West US” -P “123!@#qweQWE” -x “thiago” -r “role[iis]” -VV

INFO: validating…

INFO: creating…

INFO: calling get hostedservices/az-933158e2aac5 synchronously

.DEBUG: <?xml version="1.0"?>

<Error xmlns=“http://schemas.microsoft.com/windowsazure” xmlns:i="http://www.w3.

org/2001/XMLSchema-instance">

ResourceNotFound

The hosted service does not exist.

WARN: ResourceNotFound : The hosted service does not exist.

WARN: Unable to find hosted(cloud) service:ResourceNotFound : The hosted service

does not exist.

INFO: calling get storageservices synchronously

.INFO: calling get images synchronously

.INFO: calling post hostedservices synchronously

DEBUG: <?xml version="1.0"?>

az-933158e2aac5

YXotOTMzMTU4ZTJhYWM1

Explicitly created hosted service

West US

.INFO: Waiting while status returns InProgress

DEBUG: not InProgress : <?xml version="1.0"?>

<Operation xmlns=“http://schemas.microsoft.com/windowsazure” xmlns:i="http://www

.w3.org/2001/XMLSchema-instance">

fea68b2d-9ea6-1f56-a2f8-479144387772

Succeeded

200

INFO: calling get hostedservices/az-933158e2aac5 synchronously

.INFO: calling get hostedservices/az-933158e2aac5/deploymentslots/Production syn

chronously

.DEBUG: <?xml version="1.0"?>

<Error xmlns=“http://schemas.microsoft.com/windowsazure” xmlns:i="http://www.w3.

org/2001/XMLSchema-instance">

ResourceNotFound

No deployments were found.

WARN: ResourceNotFound : No deployments were found.

INFO: calling post hostedservices/az-933158e2aac5/deployments synchronously

DEBUG: <?xml version="1.0"?>

<Deployment xmlns=“http://schemas.microsoft.com/windowsazure” xmlns:i="http://ww

w.w3.org/2001/XMLSchema-instance">

az-933158e2aac5

Production

YXotOTMzMTU4ZTJhYWM1

az-933158e2aac5

PersistentVMRole

WindowsProvisioningConfiguration</ConfigurationSetType

az-933158e2aac5

123!@#qweQWE

false

false

thiago

Http

NetworkConfiguration

5985

WinRM

5985

TCP

YXotOTMzMTU4ZTJhYWM1

disk_6a44d4dc-f280-40ef-8be1-4aaab79a7037

http://az3642f7cbd4cdqtykqjavdy.blob.core.windows.net/vhds/disk_6a4

4d4dc-f280-40ef-8be1-4aaab79a7037.vhd

a699494373c04fc0bc8f2bb1389d6106__Windows-Server-2012-Datacen

ter-201408.01-en.us-127GB.vhd

Small

.INFO: Waiting while status returns InProgress

.DEBUG: not InProgress : <?xml version="1.0"?>

<Operation xmlns=“http://schemas.microsoft.com/windowsazure” xmlns:i="http://www

.w3.org/2001/XMLSchema-instance">

0c3ccde1-cdc8-1128-bb5a-6ca3422f0b80

Succeeded

200

INFO: calling get hostedservices/az-933158e2aac5 synchronously

.INFO: calling get hostedservices/az-933158e2aac5/deploymentslots/Production syn

chronously

.

Waiting for virtual machine to reach status 'provisioning’INFO: calling get host

edservices/az-933158e2aac5/deploymentslots/Production synchronously

…INFO: calling get hostedservices/az-933158e2aac5/deploymentslots/Production sy

nchronously

…INFO: calling get hostedservices/az-933158e2aac5/deploymentslots/Production sy

nchronously

.DEBUG: Role status is RoleStateUnknown

.INFO: calling get hostedservices/az-933158e2aac5/deploymentslots/Production syn

chronously

.DEBUG: Role status is RoleStateUnknown

.INFO: calling get hostedservices/az-933158e2aac5/deploymentslots/Production syn

chronously

.DEBUG: Role status is RoleStateUnknown

.INFO: calling get hostedservices/az-933158e2aac5/deploymentslots/Production syn

chronously

.DEBUG: Role status is RoleStateUnknown

.INFO: calling get hostedservices/az-933158e2aac5/deploymentslots/Production syn

chronously

.DEBUG: Role status is Provisioning

.vm state ‘provisioning’ reached after 3.2 minutes.

Waiting for virtual machine to reach status 'ready’INFO: calling get hostedservi

ces/az-933158e2aac5/deploymentslots/Production synchronously

.DEBUG: Role status is Provisioning

.INFO: calling get hostedservices/az-933158e2aac5/deploymentslots/Production syn

chronously

.DEBUG: Role status is Provisioning

.INFO: calling get hostedservices/az-933158e2aac5/deploymentslots/Production syn

chronously

.DEBUG: Role status is Provisioning

.INFO: calling get hostedservices/az-933158e2aac5/deploymentslots/Production syn

chronously

.DEBUG: Role status is Provisioning

.INFO: calling get hostedservices/az-933158e2aac5/deploymentslots/Production syn

chronously

.DEBUG: Role status is ReadyRole

.vm state ‘ready’ reached after 2.15 minutes.

INFO: calling get hostedservices/az-933158e2aac5/deploymentslots/Production sync

hronously

.

DNS Name: az-933158e2aac5.cloudapp.net

VM Name: az-933158e2aac5

Size: Small

Azure Source Image: a699494373c04fc0bc8f2bb1389d6106__Windows-Server-2012-Datace

nter-201408.01-en.us-127GB.vhd

Azure Service Location: West US

Public Ip Address: 104.40.0.138

Private Ip Address: 100.74.192.93

WinRM Port: 5985

Environment: _default

Runlist: [“role[iis]”]

INFO: calling get hostedservices/az-933158e2aac5/deploymentslots/Production sync

hronously

.

DNS Name: az-933158e2aac5.cloudapp.net

VM Name: az-933158e2aac5

Size: Small

Azure Source Image: a699494373c04fc0bc8f2bb1389d6106__Windows-Server-2012-Datace

nter-201408.01-en.us-127GB.vhd

Azure Service Location: West US

Public Ip Address: 104.40.0.138

Private Ip Address: 100.74.192.93

WinRM Port: 5985

Environment: _default

Runlist: [“role[iis]”]

Waiting for winrm on 104.40.0.138:5985

Waiting for remote response before bootstrap.DEBUG: Adding 104.40.0.138

DEBUG: :session => :init

DEBUG: :relay_to_servers => echo . & echo Response received.

DEBUG: :relayed => 104.40.0.138

DEBUG: 104.40.0.138 => :run_command

ERROR: No response received from remote node after 0.01 minutes, giving up.

ERROR: RuntimeError: Command execution failed.

C:\Users\thiago>

[cid:image001.png@01CF90AC.B190B860]

Thiago Custódio
Software Engineer
BR Soluções Integradas
thiago.custodio@brsolucoesintegradas.com.brmailto:thiago.custodio@brsolucoesintegradas.com.br
Fixo:+55-11-5594-6029
Celular: +55-11-98237-3343
[cid:image002.png@01CF0C9D.8AABD6F0]https://twitter.com/thdotnet[cid:image003.png@01CF0C9D.8AABD6F0]https://www.facebook.com/thiago.custodio [cid:image006.png@01CF0C9D.8AABD6F0] http://thiagocustodio.azurewebsites.net/ [cid:image007.png@01CF0C9D.8AABD6F0]