Executing chef client resulted in Validation error


I am using "rundeck" supermarket chef cookbook to install rundeck application, this has dependencies on apache2 & java.
When I ran chef client I can see the required dependencies been loaded but it showing a below listed error.

Relevant File Content:


4: default: lazy { "#{apache_dir}/conf-available" },
5: description: 'Path to the conf-available directory'
7: property :root_group, String,
8: default: lazy { default_apache_root_group },
9: description: ''
11>> property :template_cookbook, String,
12: default: 'apache2',
13: description: 'Cookbook to source the template from. Override this to provide your own template'
15: property :options, Hash,
16: default: {
17: server_tokens: 'Prod',
18: server_signature: 'On',
19: trace_enable: 'Off',
20: },

System Info:

ruby=ruby 2.4.2p198 (2017-09-14 revision 59899) [x86_64-linux]
program_name=chef-client worker: ppid=138;start=20:52:37;

Running handlers:
[2019-09-24T20:52:39+00:00] ERROR: Running exception handlers
Running handlers complete
[2019-09-24T20:52:39+00:00] ERROR: Exception handlers complete
Chef Client failed. 0 resources updated in 01 seconds
[2019-09-24T20:52:39+00:00] FATAL: Stacktrace dumped to /opt/kitchen/cache/chef-stacktrace.out
[2019-09-24T20:52:39+00:00] FATAL: Please provide the contents of the stacktrace.out file if you file a bug report
[2019-09-24T20:52:39+00:00] ERROR: Validation map has unknown check: description

I think you have to update your chef-client version to 13.9 for that version of the apache2 cookbook to work.

This is the same error as https://github.com/sous-chefs/apache2/issues/637

I have upgraded chef (Chef: 14.13.11), still getting the same error.

Can you show the error with chef-client 14? it can't be exactly the same.

Allow me to correct myself, as you mentioned upgrading the chef client did worked.

Thank you!