File copy from Windows Share Error


#1

Hi Chefs,
I’m having trouble with a recipe copying a file from a windows share. I’ve tried using powershell, batch and now native ruby to do it.
I’ve removed the file share and rebooted the windows server and re-created the share, still the same issue. Google is not throwing up anything useful but I suspect this is a Chef related issue.
Error is;
"DEBUG: :relay_output_from_backend => ["ATLQ-CHEF04 ", “[2014-07-31T12:23:06-04:00] FATAL: Errno::EACCES: Permission denied - \\ATLQ-CHEF01. \server.installs\dll.drops\7.1_HF05_Overlay_SAML_fix.zip\r\n<file:///\\ATLQ-CHEF01.%20\server.installs\dll.drops\7.1_HF05_Overlay_SAML_fix.zip\r\n>”]"
I’ve got local accounts on both windows nodes that use the same username/password for Chef client to run. File copy from either server works fine when logged it as that user, but when run in Chef, it will only work on the server that is hosting the share, the other server fails.
Share permissions and NTFS permissions are set read/write/modify for Everyone and Users groups.
Can anyone shed any light on what on earth might be causing this?
I’ve tried to run the knife winrm command using the local accounts and with a domain account and the same issue reccurs.

Code is: “FileUtils.cp_r(source, dest)”

Thanks
Chris