Gem Versions


#1

Ohai,

I am trying to use httparty in a recipe but running into version issues. Chef is using the embedded gems and has both json 1.8.1 and json 1.5.5 installed. *I tried to uinstall json 1.5.5 but it breaks chef. When I try to use httparty in my recipe, I get the error - json 1.8.1 conflicts with json 1.5.5. When I try to set it to use that version (gem ‘json’, ‘1.8.1’), I get this error: can’t activate json-1.8.1, already activated json-1.5.5.

My googlefu comes up with nothing helpful. Thanks for any pointers!

-J


#2

I have run into a similar issue before and the only way I got around it
was to explicitly install httparty version 0.11.0 (it does not have the
same dependency). Not sure if that is the best way though. Curious to see
if anyone else has input.

  • David Crowder

On 12/9/13 3:47 PM, “Jenn Fountain” jfountain@meetme.com wrote:

Ohai,

I am trying to use httparty in a recipe but running into version issues.
Chef is using the embedded gems and has both json 1.8.1 and json 1.5.5
installed. *I tried to uinstall json 1.5.5 but it breaks chef. When I
try to use httparty in my recipe, I get the error - json 1.8.1 conflicts
with json 1.5.5. When I try to set it to use that version (gem ‘json’,
Œ1.8.1¹), I get this error: can’t activate json-1.8.1, already activated
json-1.5.5.

My googlefu comes up with nothing helpful. Thanks for any pointers!

-J

CONFIDENTIALITY NOTICE This message and any included attachments are from Cerner Corporation and are intended only for the addressee. The information contained in this message is confidential and may constitute inside or non-public information under international, federal, or state securities laws. Unauthorized forwarding, printing, copying, distribution, or use of such information is strictly prohibited and may be unlawful. If you are not the addressee, please promptly delete this message and notify the sender of the delivery error by e-mail or you may call Cerner’s corporate offices in Kansas City, Missouri, U.S.A at (+1) (816)221-1024.


#3

Jenn,

Can you tell us what version of Chef you’re using, and how it’s installed?

-M

On Mon, Dec 9, 2013 at 4:51 PM, Crowder,David David.Crowder@cerner.comwrote:

I have run into a similar issue before and the only way I got around it
was to explicitly install httparty version 0.11.0 (it does not have the
same dependency). Not sure if that is the best way though. Curious to see
if anyone else has input.

  • David Crowder

On 12/9/13 3:47 PM, “Jenn Fountain” jfountain@meetme.com wrote:

Ohai,

I am trying to use httparty in a recipe but running into version issues.
Chef is using the embedded gems and has both json 1.8.1 and json 1.5.5
installed. *I tried to uinstall json 1.5.5 but it breaks chef. When I
try to use httparty in my recipe, I get the error - json 1.8.1 conflicts
with json 1.5.5. When I try to set it to use that version (gem ‘json’,
Œ1.8.1¹), I get this error: can’t activate json-1.8.1, already activated
json-1.5.5.

My googlefu comes up with nothing helpful. Thanks for any pointers!

-J

CONFIDENTIALITY NOTICE This message and any included attachments are from
Cerner Corporation and are intended only for the addressee. The information
contained in this message is confidential and may constitute inside or
non-public information under international, federal, or state securities
laws. Unauthorized forwarding, printing, copying, distribution, or use of
such information is strictly prohibited and may be unlawful. If you are not
the addressee, please promptly delete this message and notify the sender of
the delivery error by e-mail or you may call Cerner’s corporate offices in
Kansas City, Missouri, U.S.A at (+1) (816)221-1024.


#4

yup. i had to freeze httparty , due to the hipchat handler.

On Mon, Dec 9, 2013 at 1:51 PM, Crowder,David David.Crowder@cerner.comwrote:

I have run into a similar issue before and the only way I got around it
was to explicitly install httparty version 0.11.0 (it does not have the
same dependency). Not sure if that is the best way though. Curious to see
if anyone else has input.

  • David Crowder

On 12/9/13 3:47 PM, “Jenn Fountain” jfountain@meetme.com wrote:

Ohai,

I am trying to use httparty in a recipe but running into version issues.
Chef is using the embedded gems and has both json 1.8.1 and json 1.5.5
installed. *I tried to uinstall json 1.5.5 but it breaks chef. When I
try to use httparty in my recipe, I get the error - json 1.8.1 conflicts
with json 1.5.5. When I try to set it to use that version (gem ‘json’,
Œ1.8.1¹), I get this error: can’t activate json-1.8.1, already activated
json-1.5.5.

My googlefu comes up with nothing helpful. Thanks for any pointers!

-J

CONFIDENTIALITY NOTICE This message and any included attachments are from
Cerner Corporation and are intended only for the addressee. The information
contained in this message is confidential and may constitute inside or
non-public information under international, federal, or state securities
laws. Unauthorized forwarding, printing, copying, distribution, or use of
such information is strictly prohibited and may be unlawful. If you are not
the addressee, please promptly delete this message and notify the sender of
the delivery error by e-mail or you may call Cerner’s corporate offices in
Kansas City, Missouri, U.S.A at (+1) (816)221-1024.


#5

chef-11.6.0-1.el6.x86_64

yum install chef

On Dec 9, 2013, at 5:06 PM, Mike miketheman@gmail.com wrote:

Jenn,

Can you tell us what version of Chef you’re using, and how it’s installed?

-M

On Mon, Dec 9, 2013 at 4:51 PM, Crowder,David David.Crowder@cerner.com wrote:
I have run into a similar issue before and the only way I got around it
was to explicitly install httparty version 0.11.0 (it does not have the
same dependency). Not sure if that is the best way though. Curious to see
if anyone else has input.

  • David Crowder

On 12/9/13 3:47 PM, “Jenn Fountain” jfountain@meetme.com wrote:

Ohai,

I am trying to use httparty in a recipe but running into version issues.
Chef is using the embedded gems and has both json 1.8.1 and json 1.5.5
installed. *I tried to uinstall json 1.5.5 but it breaks chef. When I
try to use httparty in my recipe, I get the error - json 1.8.1 conflicts
with json 1.5.5. When I try to set it to use that version (gem ‘json’,
Œ1.8.1¹), I get this error: can’t activate json-1.8.1, already activated
json-1.5.5.

My googlefu comes up with nothing helpful. Thanks for any pointers!

-J

CONFIDENTIALITY NOTICE This message and any included attachments are from Cerner Corporation and are intended only for the addressee. The information contained in this message is confidential and may constitute inside or non-public information under international, federal, or state securities laws. Unauthorized forwarding, printing, copying, distribution, or use of such information is strictly prohibited and may be unlawful. If you are not the addressee, please promptly delete this message and notify the sender of the delivery error by e-mail or you may call Cerner’s corporate offices in Kansas City, Missouri, U.S.A at (+1) (816)221-1024.


#6

Hi Jenn,

I can definitely confirm what Ranjib & David mentioned.

In httparty 0.12.0, the maintainer decided to constrain their dependency on
json 1.8.x and above, whereas Chef 11 will not currently allow anything
beyond json 1.7.7, hence the conflict.

If you’re using a Gemfile/gemspec, I’d add gem 'httparty', '< 0.12.0' or
explicitly gem 'httparty', '0.11.0' for now, and document the reasoning.

If installing via chef_gem, then:
chef_gem ‘httparty’ do
version '0.11.0’
end

Hope this helps,
-M

On Tue, Dec 10, 2013 at 7:12 AM, Jenn Fountain jfountain@meetme.com wrote:

chef-11.6.0-1.el6.x86_64

yum install chef

On Dec 9, 2013, at 5:06 PM, Mike miketheman@gmail.com wrote:

Jenn,

Can you tell us what version of Chef you’re using, and how it’s installed?

-M

On Mon, Dec 9, 2013 at 4:51 PM, Crowder,David David.Crowder@cerner.comwrote:

I have run into a similar issue before and the only way I got around it
was to explicitly install httparty version 0.11.0 (it does not have the
same dependency). Not sure if that is the best way though. Curious to see
if anyone else has input.

  • David Crowder

On 12/9/13 3:47 PM, “Jenn Fountain” jfountain@meetme.com wrote:

Ohai,

I am trying to use httparty in a recipe but running into version issues.
Chef is using the embedded gems and has both json 1.8.1 and json 1.5.5
installed. *I tried to uinstall json 1.5.5 but it breaks chef. When I
try to use httparty in my recipe, I get the error - json 1.8.1 conflicts
with json 1.5.5. When I try to set it to use that version (gem ‘json’,
Œ1.8.1¹), I get this error: can’t activate json-1.8.1, already activated
json-1.5.5.

My googlefu comes up with nothing helpful. Thanks for any pointers!

-J

CONFIDENTIALITY NOTICE This message and any included attachments are from
Cerner Corporation and are intended only for the addressee. The information
contained in this message is confidential and may constitute inside or
non-public information under international, federal, or state securities
laws. Unauthorized forwarding, printing, copying, distribution, or use of
such information is strictly prohibited and may be unlawful. If you are not
the addressee, please promptly delete this message and notify the sender of
the delivery error by e-mail or you may call Cerner’s corporate offices in
Kansas City, Missouri, U.S.A at (+1) (816)221-1024.


#7

Thanks. That is why I ended up doing and works.

Thanks again!
On Dec 10, 2013, at 8:35 AM, Mike miketheman@gmail.com wrote:

Hi Jenn,

I can definitely confirm what Ranjib & David mentioned.

In httparty 0.12.0, the maintainer decided to constrain their dependency on json 1.8.x and above, whereas Chef 11 will not currently allow anything beyond json 1.7.7, hence the conflict.

If you’re using a Gemfile/gemspec, I’d add gem 'httparty', '< 0.12.0' or explicitly gem 'httparty', '0.11.0' for now, and document the reasoning.

If installing via chef_gem, then:
chef_gem ‘httparty’ do
version '0.11.0’
end

Hope this helps,
-M

On Tue, Dec 10, 2013 at 7:12 AM, Jenn Fountain jfountain@meetme.com wrote:
chef-11.6.0-1.el6.x86_64

yum install chef

On Dec 9, 2013, at 5:06 PM, Mike miketheman@gmail.com wrote:

Jenn,

Can you tell us what version of Chef you’re using, and how it’s installed?

-M

On Mon, Dec 9, 2013 at 4:51 PM, Crowder,David David.Crowder@cerner.com wrote:
I have run into a similar issue before and the only way I got around it
was to explicitly install httparty version 0.11.0 (it does not have the
same dependency). Not sure if that is the best way though. Curious to see
if anyone else has input.

  • David Crowder

On 12/9/13 3:47 PM, “Jenn Fountain” jfountain@meetme.com wrote:

Ohai,

I am trying to use httparty in a recipe but running into version issues.
Chef is using the embedded gems and has both json 1.8.1 and json 1.5.5
installed. *I tried to uinstall json 1.5.5 but it breaks chef. When I
try to use httparty in my recipe, I get the error - json 1.8.1 conflicts
with json 1.5.5. When I try to set it to use that version (gem ‘json’,
Œ1.8.1¹), I get this error: can’t activate json-1.8.1, already activated
json-1.5.5.

My googlefu comes up with nothing helpful. Thanks for any pointers!

-J

CONFIDENTIALITY NOTICE This message and any included attachments are from Cerner Corporation and are intended only for the addressee. The information contained in this message is confidential and may constitute inside or non-public information under international, federal, or state securities laws. Unauthorized forwarding, printing, copying, distribution, or use of such information is strictly prohibited and may be unlawful. If you are not the addressee, please promptly delete this message and notify the sender of the delivery error by e-mail or you may call Cerner’s corporate offices in Kansas City, Missouri, U.S.A at (+1) (816)221-1024.