How to disable reporting during each chef-client run


#1

on the chef server we do not have reporting enabled. so we do not want each client to spend time and error out trying to send reporting data.


#2

Add:

enable_reporting false

to your /etc/chef/client.rb or whichever config file you’re using.

https://github.com/chef/chef/blob/master/chef-config/lib/chef-config/config.rb contains the possible configuration options for the chef client.
-Thom


#3

thank you!! that fixed the issue