How to mount CIFS with "mount" resource?

Hi, I tried to mount CIFS with "mount" resource but doing something like this:

mount '/mnt/directory' do
  password PASSWORD
  username USERNAME
  device "//"
  fstype 'cifs'
  pass   0
  action [:mount]

results in getting:

Please enter password with the systemd-tty-ask-password-agent tool!

While just doing this works:

execute 'mount-cifs' do
  command "mount.cifs -o soft,uid=0,forceuid,gid=0,forcegid,username=USERNAME,password=PASSWORD // /mnt/directory"

Why is that? And what is the proper way to pass options like "forceuid,gid=0,forcegid" etc to the "mount" resource?

Ok, I have to answer my own questions. "password" and "username" is used on Windows only. I had to pass username and password as "options":

mount '/some/path' do
  options "username=USERNAME,password=PASSWORD"