Install-runner fails due to ERROR: 413 "Request Entity Too Large"


#1

Trying to set up a runner for automate I’m getting the error 413 request entity to large message.

I can get the node to connect to the chef server by disabling the passwd ohai plugin, but after doing that the runner doesn’t show up in automate.

I’ve tried setting up the .chef/bootstrap/conf.d/disabled_plurgins.rb file to disable the :Passwd plugin, but that doesn’t seem to be read by automate-ctl.

What can be done to disable ohai plugins when automate-ctl is running? Or alternatively are there steps to take to finish a runner being set up after manually intervening to join it to the chef server?


#2

I’ve worked around this by adding Ohai::Config[:disabled_plugins] = [ :Passwd ] to
/opt/delivery/embedded/lib/ruby/gems/2.2.0/gems/chef-12.15.19/lib/chef/knife/core/bootstrap _context.rb in the relevant chunk of code for the client.rb file being created.