Knife bootstrap curl: option --proxy=on: is unknown


#1

Running knife bootstrap on a new node that needs an HTTP_PROXY set to
get out to the internet, with the --bootstrap-proxy option set, knife
complains that curl doesn’t know the option --proxy=on. This is Centos
6.4, with curl 7.19.7

knife bootstrap 111.222.333.444 --ssh-user root --ssh-port 22
–ssh-password ‘sekrit’
–template-file .chef/bootstrap/chef-full.erb --run-list=role[base]
–node-name newnode01 --environment qa --bootstrap-proxy 111.222.333.1:8080

[…]
111.222.333.444 curl: option --proxy=on: is unknown
111.222.333.444 curl: try ‘curl --help’ or ‘curl --manual’ for more information
10.187.254.188 bash: line 83: chef-client: command not found

Do I not have something set right? Do I need a .curlrc on the new node
with the proxy IP set in there?


http://philcryer.com


#2

Is your bootstrap template corrupted in some way? If you look at the
one that comes with Chef, it looks like this:

if ! exists /usr/bin/chef-client; then
if exists wget; then
bash <(wget <%= "–proxy=on " if knife_config[:bootstrap_proxy] %>
{install_sh} -O -) {version_string}
elif exists curl; then
bash <(curl -L <%= “–proxy “#{knife_config[:bootstrap_proxy]}”
” if knife_config[:bootstrap_proxy] %> {install_sh}) {version_string}
else
echo “Neither wget nor curl found. Please install one and try again.” >&2
exit 1
fi
fi

So it looks like in your situation, the wget flags are getting passed
to a curl…

  • Julian

On Sun, Sep 22, 2013 at 11:38 PM, Phil Cryer phil@philcryer.com wrote:

Running knife bootstrap on a new node that needs an HTTP_PROXY set to
get out to the internet, with the --bootstrap-proxy option set, knife
complains that curl doesn’t know the option --proxy=on. This is Centos
6.4, with curl 7.19.7

knife bootstrap 111.222.333.444 --ssh-user root --ssh-port 22
–ssh-password ‘sekrit’
–template-file .chef/bootstrap/chef-full.erb --run-list=role[base]
–node-name newnode01 --environment qa --bootstrap-proxy 111.222.333.1:8080

[…]
111.222.333.444 curl: option --proxy=on: is unknown
111.222.333.444 curl: try ‘curl --help’ or ‘curl --manual’ for more information
10.187.254.188 bash: line 83: chef-client: command not found

Do I not have something set right? Do I need a .curlrc on the new node
with the proxy IP set in there?


http://philcryer.com


[ Julian C. Dunn jdunn@aquezada.com * Sorry, I’m ]
[ WWW: http://www.aquezada.com/staff/julian * only Web 1.0 ]
[ gopher://sdf.org/1/users/keymaker/ * compliant! ]
[ PGP: 91B3 7A9D 683C 7C16 715F 442C 6065 D533 FDC2 05B9 ]


#3

On Mon, Sep 23, 2013 at 3:18 PM, Julian C. Dunn jdunn@aquezada.com wrote:

Is your bootstrap template corrupted in some way? If you look at the
one that comes with Chef, it looks like this:

if ! exists /usr/bin/chef-client; then
if exists wget; then
bash <(wget <%= "–proxy=on " if knife_config[:bootstrap_proxy] %>
{install_sh} -O -) {version_string}
elif exists curl; then
bash <(curl -L <%= “–proxy “#{knife_config[:bootstrap_proxy]}”
” if knife_config[:bootstrap_proxy] %> {install_sh}) {version_string}
else
echo “Neither wget nor curl found. Please install one and try again.” >&2
exit 1
fi
fi

So it looks like in your situation, the wget flags are getting passed
to a curl…

Thanks, seems obvious now, but it took you pointing it out. Thanks!

On Sun, Sep 22, 2013 at 11:38 PM, Phil Cryer phil@philcryer.com wrote:

Running knife bootstrap on a new node that needs an HTTP_PROXY set to
get out to the internet, with the --bootstrap-proxy option set, knife
complains that curl doesn’t know the option --proxy=on. This is Centos
6.4, with curl 7.19.7

knife bootstrap 111.222.333.444 --ssh-user root --ssh-port 22
–ssh-password ‘sekrit’
–template-file .chef/bootstrap/chef-full.erb --run-list=role[base]
–node-name newnode01 --environment qa --bootstrap-proxy 111.222.333.1:8080

[…]
111.222.333.444 curl: option --proxy=on: is unknown
111.222.333.444 curl: try ‘curl --help’ or ‘curl --manual’ for more information
10.187.254.188 bash: line 83: chef-client: command not found

Do I not have something set right? Do I need a .curlrc on the new node
with the proxy IP set in there?


http://philcryer.com


[ Julian C. Dunn jdunn@aquezada.com * Sorry, I’m ]
[ WWW: http://www.aquezada.com/staff/julian * only Web 1.0 ]
[ gopher://sdf.org/1/users/keymaker/ * compliant! ]
[ PGP: 91B3 7A9D 683C 7C16 715F 442C 6065 D533 FDC2 05B9 ]


http://philcryer.com