New deb packages under apt.opscode.com


#1

Hello.

I’m use chef(server,client and other) under ubuntu lucid. All works
fine.
But that packages under debian lenny has some troubles like: packages
chefdoes not install libuuidtools-ruby (knife not working).
Install process not generate /etc/chef/client.pem. May be some others…

Who can correct mistakes and get worked debian lenny packages for chef
0.9 ?

And last question - what is the best method to connect new chef-client
automatic to already worked server? (i do not want to go to the
chef-server and apply registrations… or add client by hand)

Thank You for answers.


Vasiliy G Tolstov v.tolstov@selfip.ru
Selfip.Ru


#2

Hello!

I have updated the packaging on the APT repository so that the Chef library package (libchef-ruby1.8) depends on libuuidtools-ruby1.8, so that knife will function.

The installation process cannot generate a client.pem, as that is either created via using the validation certificate, or with the knife client create command. See the authentication documentation for more information.

http://wiki.opscode.com/display/chef/Authentication

To automatically validate new clients, you would need to have in your provisioning process a way to put the validation.pem in /etc/chef on new systems. This could be retrieved via late commands in the preseeding from an internal web server, or via scp similar to the way the knife bootstrap subcommand works.

On Jul 6, 2010, at 1:12 AM, Vasiliy G Tolstov wrote:

Hello.

I’m use chef(server,client and other) under ubuntu lucid. All works
fine.
But that packages under debian lenny has some troubles like: packages
chefdoes not install libuuidtools-ruby (knife not working).
Install process not generate /etc/chef/client.pem. May be some others…

Who can correct mistakes and get worked debian lenny packages for chef
0.9 ?

And last question - what is the best method to connect new chef-client
automatic to already worked server? (i do not want to go to the
chef-server and apply registrations… or add client by hand)

Thank You for answers.


Vasiliy G Tolstov v.tolstov@selfip.ru
Selfip.Ru


Opscode, Inc
Joshua Timberman, Senior Solutions Engineer
C: 720.334.RUBY E: joshua@opscode.com


#3

В Втр, 06/07/2010 в 12:29 -0600, Joshua Timberman пишет:

Hello!

I have updated the packaging on the APT repository so that the Chef
library package (libchef-ruby1.8) depends on libuuidtools-ruby1.8, so
that knife will function.

Hm… another problem:

cf-server:~# apt-get install chef-server
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
chef-server: Depends: chef-server-api (= 0.9.6+dfsg-2) but it is not
going to be installed
Depends: chef-server-webui (= 0.9.6+dfsg-2) but it is not
going to be installed
Depends: chef-solr (= 0.9.6+dfsg-2) but it is not going
to be installed
E: Broken packages


Vasiliy G Tolstov v.tolstov@selfip.ru
Selfip.Ru