Opscode-manage installed - and then?


#1

Hi,

I installed the chef-server on premise.
The tutorial advises to download a starter-kit from the management website, so I installed the opscode-manage plugin (for my test-purposes, 25 nodes should be OK).

However, when I go to the URL of my chef-server, there’s no way to login.
Is there a specific location one has to use?

Is there a way to verify that the install worked?

[root@my-chef nginx]# chef-server-ctl status
run: bookshelf: (pid 761) 767s; run: log: (pid 760) 767s
run: nginx: (pid 758) 767s; run: log: (pid 757) 767s
run: oc_bifrost: (pid 745) 767s; run: log: (pid 743) 767s
run: oc_id: (pid 746) 767s; run: log: (pid 744) 767s
run: opscode-erchef: (pid 741) 767s; run: log: (pid 739) 767s
run: opscode-expander: (pid 756) 767s; run: log: (pid 755) 767s
run: opscode-expander-reindexer: (pid 753) 767s; run: log: (pid 751) 767s
run: opscode-solr4: (pid 740) 767s; run: log: (pid 736) 767s
run: postgresql: (pid 747) 767s; run: log: (pid 742) 767s
run: rabbitmq: (pid 735) 767s; run: log: (pid 734) 767s
run: redis_lb: (pid 767) 767s; run: log: (pid 766) 767s

This is a CentOS7 64bit install, if it’s of any interest.


#2

What do u get when u go to the website ? Is it api interface or login page
if login page then create an Id for ur self . and you would need an
organization to be created .

Cheers,
Vishnu
On Sep 5, 2015 10:23 PM, “Rainer Duffner” chef@ultra-secure.de wrote:

Hi,

I installed the chef-server on premise.
The tutorial advises to download a starter-kit from the management
website, so I installed the opscode-manage plugin (for my test-purposes, 25
nodes should be OK).

However, when I go to the URL of my chef-server, there’s no way to login.
Is there a specific location one has to use?

Is there a way to verify that the install worked?

[root@my-chef nginx]# chef-server-ctl status
run: bookshelf: (pid 761) 767s; run: log: (pid 760) 767s
run: nginx: (pid 758) 767s; run: log: (pid 757) 767s
run: oc_bifrost: (pid 745) 767s; run: log: (pid 743) 767s
run: oc_id: (pid 746) 767s; run: log: (pid 744) 767s
run: opscode-erchef: (pid 741) 767s; run: log: (pid 739) 767s
run: opscode-expander: (pid 756) 767s; run: log: (pid 755) 767s
run: opscode-expander-reindexer: (pid 753) 767s; run: log: (pid 751) 767s
run: opscode-solr4: (pid 740) 767s; run: log: (pid 736) 767s
run: postgresql: (pid 747) 767s; run: log: (pid 742) 767s
run: rabbitmq: (pid 735) 767s; run: log: (pid 734) 767s
run: redis_lb: (pid 767) 767s; run: log: (pid 766) 767s

This is a CentOS7 64bit install, if it’s of any interest.


#3

Am 05.09.2015 um 19:22 schrieb vishnu g.vishnuvardhansharma@gmail.com:

What do u get when u go to the website ? Is it api interface or login page if login page then create an Id for ur self . and you would need an organization to be created .

Cheers,
Vishnu

I just get the „Chef Server API“ page.
I’ve already created a user (and an organization).

I expected the website to show a login form upon installation of opscode-manage…


#4

Your firewall is blocking it can u please check if u have firewall running
?
On Sep 5, 2015 11:01 PM, “Rainer Duffner” chef@ultra-secure.de wrote:

Am 05.09.2015 um 19:22 schrieb vishnu g.vishnuvardhansharma@gmail.com:

What do u get when u go to the website ? Is it api interface or login page
if login page then create an Id for ur self . and you would need an
organization to be created .

Cheers,
Vishnu

I just get the „Chef Server API“ page.
I’ve already created a user (and an organization).

I expected the website to show a login form upon installation of
opscode-manage…


#5

Am 05.09.2015 um 19:39 schrieb vishnu g.vishnuvardhansharma@gmail.com:

Your firewall is blocking it can u please check if u have firewall running ?

No, I’ve (hopefully) stopped that.

[root@my-chef ~]# systemctl list-units --all |grep ipt
iptables.service not-found inactive dead iptables.service
[root@my-chef ~]# systemctl list-units --all |grep fire
[root@my-chef ~]#


#6

Ok that is interesting, I usually hit this firewall … So you have
installed and did reconfigure command with chef-server-ctl ? And when u try
to access the website u get only api interface ? So have u installed
opscode manage and did the reconfigure on that as well usig opscode-manage
reconfigure ?

Cheers,
Vishnu
On Sep 5, 2015 11:21 PM, “Rainer Duffner” chef@ultra-secure.de wrote:

Am 05.09.2015 um 19:39 schrieb vishnu g.vishnuvardhansharma@gmail.com:

Your firewall is blocking it can u please check if u have firewall running
?

No, I’ve (hopefully) stopped that.

[root@my-chef ~]# systemctl list-units --all |grep ipt
iptables.service
not-found inactive dead
iptables.service
[root@my-chef ~]# systemctl list-units --all |grep fire
[root@my-chef ~]#


#7

Am 05.09.2015 um 20:04 schrieb vishnu g.vishnuvardhansharma@gmail.com:

Ok that is interesting, I usually hit this firewall … So you have installed and did reconfigure command with chef-server-ctl ? And when u try to access the website u get only api interface ? So have u installed opscode manage and did the reconfigure on that as well usig opscode-manage reconfigure ?

Yes, precisely.
The documentation is pretty clear on this part at least.

I saw:
[root@my-chef ~]# cat /etc/sysconfig/selinux

This file controls the state of SELinux on the system.

SELINUX= can take one of these three values:

enforcing - SELinux security policy is enforced.

permissive - SELinux prints warnings instead of enforcing.

disabled - No SELinux policy is loaded.

SELINUX=enforcing

SELINUXTYPE= can take one of three two values:

targeted - Targeted processes are protected,

minimum - Modification of targeted policy. Only selected processes are protected.

mls - Multi Level Security protection.

SELINUXTYPE=targeted

The documentation does not (TTBOMK) mention disabling it.


#8

Oh yes please disable the selinux I had this issue too
On Sep 5, 2015 11:40 PM, “Rainer Duffner” chef@ultra-secure.de wrote:

Am 05.09.2015 um 20:04 schrieb vishnu g.vishnuvardhansharma@gmail.com:

Ok that is interesting, I usually hit this firewall … So you have
installed and did reconfigure command with chef-server-ctl ? And when u try
to access the website u get only api interface ? So have u installed
opscode manage and did the reconfigure on that as well usig opscode-manage
reconfigure ?

Yes, precisely.
The documentation is pretty clear on this part at least.

I saw:
[root@my-chef ~]# cat /etc/sysconfig/selinux

This file controls the state of SELinux on the system.

SELINUX= can take one of these three values:

enforcing - SELinux security policy is enforced.

permissive - SELinux prints warnings instead of enforcing.

disabled - No SELinux policy is loaded.

SELINUX=enforcing

SELINUXTYPE= can take one of three two values:

targeted - Targeted processes are protected,

minimum - Modification of targeted policy. Only selected processes

are protected.

mls - Multi Level Security protection.

SELINUXTYPE=targeted

The documentation does not (TTBOMK) mention disabling it.


#9

Am 05.09.2015 um 20:18 schrieb vishnu <g.vishnuvardhansharma@gmail.com mailto:g.vishnuvardhansharma@gmail.com>:

Oh yes please disable the selinux I had this issue too

Didn’t help.

[root@my-chef ~]# sestatus
SELinux status: disabled

I wanted to uninstall and then re-install the chef-manage extension with disabled selinux - but it seems there is no way to uninstall an extension.
At least, no obvious way.


#10

Hey Rainer,

Can you confirm you installed the rpm package?

rpm -qa | grep opscode

(you should see the opscode-manage package listed there)

Then run: chef-server-ctl reconfigure
and then: opscode-manage-ctl reconfigure

If you still don’t see the manage UI, then try finally running:
chef-server-ctl restart

I’m referencing: https://docs.chef.io/install_server.html under “standalone”

On Sat, Sep 5, 2015 at 2:34 PM, Rainer Duffner chef@ultra-secure.de wrote:

Am 05.09.2015 um 20:18 schrieb vishnu g.vishnuvardhansharma@gmail.com:

Oh yes please disable the selinux I had this issue too

Didn’t help.

[root@my-chef ~]# sestatus
SELinux status: disabled

I wanted to uninstall and then re-install the chef-manage extension with
disabled selinux - but it seems there is no way to uninstall an extension.
At least, no obvious way.


#11

Hi! How are things? Let’s catch up at andrew.j.brown@gmail.com

Cheers,
Andrew

Sent from my BlackBerry 10 smartphone on the Rogers network.
From: Andrew Dufour
Sent: Saturday, September 5, 2015 10:24 PM
To: chef@lists.opscode.com
Reply To: chef@lists.opscode.com
Subject: [chef] Re: Re: Re: opscode-manage installed - and then?

Hey Rainer,

Can you confirm you installed the rpm package?

rpm -qa | grep opscode

(you should see the opscode-manage package listed there)

Then run: chef-server-ctl reconfigure
and then: opscode-manage-ctl reconfigure

If you still don’t see the manage UI, then try finally running: chef-server-ctl restart

I’m referencing: https://docs.chef.io/install_server.html under “standalone”

On Sat, Sep 5, 2015 at 2:34 PM, Rainer Duffner <chef@ultra-secure.demailto:chef@ultra-secure.de> wrote:

Am 05.09.2015 um 20:18 schrieb vishnu <g.vishnuvardhansharma@gmail.commailto:g.vishnuvardhansharma@gmail.com>:

Oh yes please disable the selinux I had this issue too

Didn’t help.

[root@my-chef ~]# sestatus
SELinux status: disabled

I wanted to uninstall and then re-install the chef-manage extension with disabled selinux - but it seems there is no way to uninstall an extension.
At least, no obvious way.


#12

Am 06.09.2015 um 18:50 schrieb Andrew Brown <anbrown@blackberry.com mailto:anbrown@blackberry.com>:

Hi! How are things? Let’s catch up at andrew.j.brown@gmail.com mailto:andrew.j.brown@gmail.com

Cheers,
Andrew

opscode-manage-ctl reconfigure

did the trick.

Shame on me for missing it in the docs….