Ruby version of opscode deb packages


#1

Hi all,

							       I am

using opscode deb packages of chef, chef-server
(http://apt.opscode.com/). so I got deb-src of these packages
and I found a dependency packages list.


Depends: {shlibs:Depends}, {misc:Depends}, ruby1.8 | ruby-interpreter,
libmixlib-config-ruby (>= 1.1.2), libmixlib-c
li-ruby (>= 1.1.0), libmixlib-log-ruby (>= 1.3.0),libmixlib-authentication-ruby
(>= 1.1.0), ruby-mixlib-shellout, ohai
(>= 0.6.0), librestclient-ruby, libbunny-ruby, libjson-ruby(>=1.4.4),
libtreetop-ruby, libnet-ssh2-ruby, libnet-ssh-mu
lti-ruby,liberubis-ruby, libtreetop-ruby,
libmoneta-ruby,libhighline-ruby,libuuidtools-ruby, rubygems, ucf

so I have some questions now.

  • When will these packages be updated to use ruby1.9 ?
  • Does opscode recommend to use ruby1.8 for chef and chef-server ?

Thanks from sunny Tokyo.

– Tomokazu Bob Hirai
KDDI Web Communication Inc.


#2

On Wednesday, 18 July 2012 at 10:40, tomokazu.hirai@gmail.com wrote:

so I have some questions now.

  • When will these packages be updated to use ruby1.9 ?
    Everything up to Ubuntu 12.04 LTS (Precise) uses Ruby 1.8 as the system default [1].

If you ‘apt-get install ruby’ then it does not install Ruby 1.9 and I’m guessing this is Opscode hedging their bets somewhat since chef-client doesn’t (AFAICR) have anything which strictly requires Ruby 1.9 today?

  • Does opscode recommend to use ruby1.8 for chef and chef-server ?

If you install using the ‘Full Stack’ [2] approach then chef-client runs with Ruby 1.9 … Whether that’s a recommendation or not, I don’t know :wink:

Regards,
-Alex

[1] http://packages.ubuntu.com/precise/ruby
[2] http://www.opscode.com/chef/install/


#3

On Wed, Jul 18, 2012 at 5:40 AM, tomokazu.hirai@gmail.com wrote:

  • When will these packages be updated to use ruby1.9 ?

As Alex indicated, the dependencies are based on the default Ruby in
Debian and Ubuntu.

Debian Wheezy, which has recently “frozen,” made significant gains in
improving the ruby environment in Debian. It will be much easier for
packages to utilize the different Debian supported versions of Ruby
using ruby-switch. The Rubygems binaries will now be in
/usr/local/bin.

http://wiki.debian.org/Teams/Ruby/Packaging

  • Does opscode recommend to use ruby1.8 for chef and chef-server ?

You should use a newer version of ruby. Opscode is currently shipping
Ruby 1.9.2p290 in the omnibus packages. If you don’t have personal
feelings about packaging or Ruby, you should use the Omnibus packages.

Bryan