Opscode deb package of chef, chef-server


#1

Hi all,

I am using opscode deb packages of chef, chef-server
(http://apt.opscode.com/). so I got deb-src of these packages and I
found a dependency packages list.


Depends: {shlibs:Depends}, {misc:Depends}, ruby1.8 | ruby-interpreter, libmixlib-config-ruby (>= 1.1.2), libmixlib-cli-ruby (>= 1.1.0), libmixlib-log-ruby (>= 1.3.0),libmixlib-authentication-ruby (>= 1.1.0), ruby-mixlib-shellout, ohai
(>= 0.6.0), librestclient-ruby, libbunny-ruby, libjson-ruby(>=1.4.4), libtreetop-ruby, libnet-ssh2-ruby, libnet-ssh-multi-ruby,liberubis-ruby, libtreetop-ruby, libmoneta-ruby,libhighline-ruby,libuuidtools-ruby, rubygems, ucf

so I have some questions now.

  • When will these packages be updated to use ruby1.9 ?
  • Does opscode recommend to use ruby1.8 for chef and chef-server ?

Thanks from sunny Tokyo.


Tomokazu Bob Hirai tomokazu.hirai@gmail.com
KDDI Web Communications Inc.