Shef client mode broken in 0.9.10?


#1

Do I have something out of synch, or is this a regression?

$ sudo shef -z
loading configuration: /etc/chef/client.rb
Session type: solo
Loading…epic fail!

/usr/lib/ruby/gems/1.8/gems/chef-0.9.10/lib/chef/shef/shef_session.rb:193:in
sync_cookbooks': wrong number of arguments (1 for 0) (ArgumentError) from /usr/lib/ruby/gems/1.8/gems/chef-0.9.10/lib/chef/shef/shef_session.rb:193:inrebuild_node’
from /usr/lib/ruby/gems/1.8/gems/chef-0.9.10/lib/chef/shef/shef_session.rb:47:in
reset!' from /usr/lib/ruby/gems/1.8/gems/chef-0.9.10/lib/chef/shef/shef_session.rb:93:inloading’
from /usr/lib/ruby/gems/1.8/gems/chef-0.9.10/lib/chef/shef/shef_session.rb:46:in
reset!' from /usr/lib/ruby/gems/1.8/gems/chef-0.9.10/lib/chef/shef.rb:120:insession’
from /usr/lib/ruby/gems/1.8/gems/chef-0.9.10/lib/chef/shef.rb:129:in
init' from /usr/lib/ruby/gems/1.8/gems/chef-0.9.10/lib/chef/shef.rb:60:instart’
from /usr/lib/ruby/gems/1.8/gems/chef-0.9.10/bin/shef:34
from /usr/bin/shef:19:in `load’
from /usr/bin/shef:19

I got past this error by removing the empty hash parameter in the
listed call to sync_cookbooks…


Mark J. Reed markjreed@gmail.com


#2

It’s a bug, already fixed in master. I’ll have a release soon to fix
this and also a bug affecting chef-solo.

Dan DeLeo

On Fri, Oct 22, 2010 at 12:47 PM, Mark J. Reed markjreed@gmail.com wrote:

Do I have something out of synch, or is this a regression?

$ sudo shef -z
loading configuration: /etc/chef/client.rb
Session type: solo
Loading…epic fail!

/usr/lib/ruby/gems/1.8/gems/chef-0.9.10/lib/chef/shef/shef_session.rb:193:in
sync_cookbooks': wrong number of arguments (1 for 0) (ArgumentError) from /usr/lib/ruby/gems/1.8/gems/chef-0.9.10/lib/chef/shef/shef_session.rb:193:inrebuild_node’
from /usr/lib/ruby/gems/1.8/gems/chef-0.9.10/lib/chef/shef/shef_session.rb:47:in
reset!' from /usr/lib/ruby/gems/1.8/gems/chef-0.9.10/lib/chef/shef/shef_session.rb:93:inloading’
from /usr/lib/ruby/gems/1.8/gems/chef-0.9.10/lib/chef/shef/shef_session.rb:46:in
reset!' from /usr/lib/ruby/gems/1.8/gems/chef-0.9.10/lib/chef/shef.rb:120:insession’
from /usr/lib/ruby/gems/1.8/gems/chef-0.9.10/lib/chef/shef.rb:129:in
init' from /usr/lib/ruby/gems/1.8/gems/chef-0.9.10/lib/chef/shef.rb:60:instart’
from /usr/lib/ruby/gems/1.8/gems/chef-0.9.10/bin/shef:34
from /usr/bin/shef:19:in `load’
from /usr/bin/shef:19

I got past this error by removing the empty hash parameter in the
listed call to sync_cookbooks…


Mark J. Reed markjreed@gmail.com


#3

Thanks!

On Fri, Oct 22, 2010 at 4:17 PM, Daniel DeLeo dan@kallistec.com wrote:

It’s a bug, already fixed in master. I’ll have a release soon to fix
this and also a bug affecting chef-solo.

Dan DeLeo

On Fri, Oct 22, 2010 at 12:47 PM, Mark J. Reed markjreed@gmail.com wrote:

Do I have something out of synch, or is this a regression?

$ sudo shef -z
loading configuration: /etc/chef/client.rb
Session type: solo
Loading…epic fail!

/usr/lib/ruby/gems/1.8/gems/chef-0.9.10/lib/chef/shef/shef_session.rb:193:in
sync_cookbooks': wrong number of arguments (1 for 0) (ArgumentError) from /usr/lib/ruby/gems/1.8/gems/chef-0.9.10/lib/chef/shef/shef_session.rb:193:inrebuild_node’
from /usr/lib/ruby/gems/1.8/gems/chef-0.9.10/lib/chef/shef/shef_session.rb:47:in
reset!' from /usr/lib/ruby/gems/1.8/gems/chef-0.9.10/lib/chef/shef/shef_session.rb:93:inloading’
from /usr/lib/ruby/gems/1.8/gems/chef-0.9.10/lib/chef/shef/shef_session.rb:46:in
reset!' from /usr/lib/ruby/gems/1.8/gems/chef-0.9.10/lib/chef/shef.rb:120:insession’
from /usr/lib/ruby/gems/1.8/gems/chef-0.9.10/lib/chef/shef.rb:129:in
init' from /usr/lib/ruby/gems/1.8/gems/chef-0.9.10/lib/chef/shef.rb:60:instart’
from /usr/lib/ruby/gems/1.8/gems/chef-0.9.10/bin/shef:34
from /usr/bin/shef:19:in `load’
from /usr/bin/shef:19

I got past this error by removing the empty hash parameter in the
listed call to sync_cookbooks…


Mark J. Reed markjreed@gmail.com


Mark J. Reed markjreed@gmail.com