Azure Chef Automate Starter kit not download


#1

I run setup and it not download starter-kit ,but there is no option to download anywhere. How do i download it? I am using azure chef automate?


#2

Hello Jason,

When you ran setup was this in your browser? You should fill out a form
with your Chef Automate user details and then submit. After which your
starter kit should download.

I am checking it myself now as well.

Russell


#3

Jason,

Once you submit the form to create your Chef Automate account and you get
to the page that states everything has been setup you need to wait for the
download of your starter kit.
If you click the ‘Login to Chef Automate’ too quickly you will not get the
download.

Hope that helps.

Russell


#4

Hi,
I did fill out the form. It did go to page everything done and redirect to portal.

i decided to wipes out everything and reprovision chef automate. Fill out the form and it take me to complete page with some text and then redirect me to https://mychefautomate.centralus.cloudapp.azure.com/biscotti/setup/starter-kit but then say on the page

Internal Server Error

Even with error, i can still login with user/pass create ,just don’t know how to download starter-kit or anything else wrong.


#5

I had a similar issue with Chef-Automate in AWS MarketPlace. If the name/IP
changed it could create this issue.
Try the commands below. Not sure if there is a chef-marketplace-ctl command
in Azure. Use
the Azure equivalent. Just be sure to restart biscotti service.

#Reconfigure and restart backend sevices.
chef-marketplace-ctl hostname
chef-marketplace-ctl stop biscotti
chef-marketplace-ctl start biscotti
automate-ctl reconfigure
chef-server-ctl reconfigure
automate-ctl restart
chef-server-ctl restart
chef-server-ctl restart nginx


#6

I didn’t get a chance to do this because i delete vm. i try again without out change any parameter and it work.


#7

Can you explain what you did to make it work ? I’m having this issue too…


#8

I tried your workaround, but it’s not working.


#9

After provisioning a new Chef Automate server in Azure, you should visit the URL https:///biscotti/setup in your browser (Chrome has been the most reliable for me) - then you enter your details and click next to generate your starter kit which is served up in the browser only.

These steps are documented here: https://docs.chef.io/azure_portal.html#chef-automate - if it doesn’t work the first time, I would advise re-provisioning the machine and trying again.


#10

I’ve been trying several time to re-provision, same issue each time.
I’ve been following the instructions in the link you posted above, so I know I’m doing things right.

But I don’t understand what you’re trying to say to me. Is it a “random” bug ? No offense, but this is weird especially from a cfgmgmt box :wink:


#11

What error message do you get when you try and retrieve the starter kit?
There is not a “random” bug, but let me try and explain what happens behind the scenes - there are a few fields on that web form that can pass validation when perhaps they should not (specifically the password and the key fields).

Behind the scenes, a service is taking those users and keys and creating orgs/enterprises and users in the two different systems required - Chef Server and Chef Automate. If successful, then the starter kit is created successfully and streamed to the user via a redirect to a base64 data-url containing a the zip file in the browser. If unsuccessful, then you may end up with a situation where the user is created in one system but not the other. This error is not easily recoverable without backing out the user that failed and re-configuring the machine to send all /biscotti/setup traffic to the setup page. We choose to tell people to re-provision instead of trying to work out the state of end user machines.

Particularly I have seen users attempt to paste their SSH RSA public key in the key field on the form, yet as we are creating users in Chef Server we use an OpenSSL RSA key (PKCS#1). Leaving the field blank and adding your key later using is one route to success here. Also ensuring your password has more than 8 characters and at least one upper-case character.


#12

Hi

Marvelous, I think the bug was the password indeed. And now I’ve got my starter-kit downloaded.

Thank you


#13

I am having the same issue. I am not pasting my RSA details into the form and my password is 9 characters long. I am using the Azure Market place build (1.7.39). Any help would be great!


#14

I identified and fixed a bug today in which the initial setup would timeout resulting in this behavior. This was seemingly random since the timeout was 10 minutes and in some cases the instances were fast enough to get up and running before this timeout occurred. The new timeout is 20 minutes, which should be plenty of time to get everything configured.

I am currently working on performing the testing required by Microsoft to submit a new ARM template. My best estimate for the new version to be published is probably late this week or next depending on how quickly they process the request.


#15

I am having the same issue. I am not pasting my RSA details into the form and my password is 9 characters long. I am using the Azure Market place build (1.7.39). Any help would be great!

The next version of Automate in the Marketplace removes this field and simplifies the setup due to all confusion is has caused. Unfortunately the ARM template needs to be updated before we can make it public but it should be available soon.


#16

Hi ryanh, is there any update on this yet? I tried re-deploying from Azure this morning but the image appears to be the same, and has the same issue. (NOT FOUND).

Thanks


#17

Sorry for the delay.

I submitted another new Azure image and ARM template this afternoon. New image updates the base OS to the latest patched Ubuntu 16.04 (along with an updated version of Chef Automate), and the ARM template will fix the issues for all of the existing images. This said, we are now looking at having this available next week.

Thank you for your continued patience.


#18

Has this been resolved yet? I am still getting the same issue after a new deployment. I have tried different browsers just to be safe. Thanks