Expired license message on delivery server - applied a new eval license


I used a new eval license to create the chef delivery cluster (using SSH cookbook).
All the servers are configured and connected properly ( I can see all the servers in 'Chef server' UI).

However, when I login to delivery server, I see below message:

Time flies when you're having fun!
Your evaluation period for Chef Delivery has expired. To continue working with Delivery, email us at awesome@chef.io. We'll get you back on the road.

I logged in to the server and verified that the license file is present at:


Thanks much.


Hi Srikar,

When did you first activate Delivery? Even a new license key will not extend the evaluation period. Let’s first figure out when your initial activation took place and we can go from there.


Hi Srikar,

Something that can also help us is to extract the logs from /var/log/delivery/nginx/access.log and /var/log/delivery/delivery/current

We look forward to hear from you. Thank you!

Hi Megan/Afiune,

Thanks for getting back to me. I downloaded the license file on Jan 10th, 2016. File is attached below along with other log files.



Hi Megan,

These are new instances created on Jan 10th using the ‘Delivery Cluster’ SSH cookbook.

I ran the cluster cookbook using the license key that I got on Jan 5th. However, I tried to set a new key that I got on Jan 10th.

But, the cluster is active for only 2 days now.

Thanks and Regards,

Hi Srikar,

Could you validate that the license key is readable? If you run this command and paste the output would be helpful:

$ ls -ltra /var/opt/delivery/license

Hi Afiune,

This is the output I get:

ls -ltra /var/opt/delivery/license
total 16
-rw-r–r-- 1 delivery ubuntu 1692 Jan 10 15:01 delivery.license.original
drwxr-xr-x 9 root root 4096 Jan 10 15:02 …
-rw-r----- 1 root root 3072 Jan 11 04:21 delivery.license
drwxr-xr-x 2 delivery root 4096 Jan 11 04:21 .


Hi Afiune,

Thanks for the help. changing the mode to 755 resolved the issue.

Just as a clarification, the original file copied by the delivery-cluster recipe had READ permission. The initial launch of the application complained of the expired license. However, the issue is resolved now.

Best Regards,