I am trying to run kitchen converge but got error

[root@VMCITSNAL00CX jnj_microsoft_scom]# berks install
Resolving cookbook dependencies...
Fetching 'jnj_microsoft_scom' from source at .
Fetching cookbook index from supermarket.scm.jnj
Error retrieving universe from source: https://supermarket.scm.jnj.com/

  • [Berkshelf::APIClient::TimeoutError] Unable to connect to: https://supermarket.scm.jnj.com/
    Unable to satisfy constraints on package jnj_agents, which does not exist, due to solution constraint (jnj_microsoft_scom = 1.0.26). Solution constraints that may result in a constraint on jnj_agents: [(jnj_microsoft_scom = 1.0.26) -> (jnj_agents >= 0.0.0)]
    Missing artifacts: jnj_agents
    Demand that cannot be met: (jnj_microsoft_scom = 1.0.26)
    Unable to find a solution for demands: jnj_microsoft_scom (1.0.26)

When I tried to run Kitchen converge It shows the same error

In my metadata.rb we have depends "jnj_agents"

Is there any other option like instead of using chef market we can clone jnj_agent cookbook and mention the path of this cookbook in metada.rb

please help me out

check your berksfile. the source pointing to your internal supermarket is the issue. If internal supermarket is not available to download dependencies then you'll have to figure out all deps and deps of deps then add a cookbook entry for each pointing to location on disk, git, etc... This is where an internal supermarket or the default community supermarket is useful as the default source is referenced once and should be able to find all deps in there. Multiple default sources can be defined in priority order from top to bottom. But for berks install command they all have to be reachable otherwise you'll get the same error.