Knife-google and chefdk 2.0+

I seem to be running into a gem conflict. when i chef gem install knife-google it installs fine, pulling in google-api-client 0.9.28 as a dependency.
however, google-api-client 0.8.7 is already installed via chefdk and any time I try to run knife google it errors out, saying 0.8.7 doesn’t meet the requirements.
Is there some way to “show” knife-google where to find the right version of google-api-client? Or some other way I can get this working?

linux mint 18.1
Chef Development Kit Version: 2.1.11
chef-client version: 13.2.20
delivery version: master (73ebb72a6c42b3d2ff5370c476be800fee7e5427)
berks version: 6.3.0
kitchen version: 1.17.0
inspec version: 1.33.1

Not a fix, but for anyone facing this same issue that finds this post downgrading to chefdk 1.6.1 gets me a working knife-google for now (also resolved some issue with chef-provisioning).

We’re working on these, there are some issues with how appbundler works causing conflicts with gem dependencies between stuff included and not included in ChefDK.

thanks for all the hard work.