Knife-rackspace 0.7.0 is out


#1

Just wanted to let everyone know that knife-rackspace 0.7.0 is now available on RubyGems. It has a whole lot of great fixes and I’d really like to thank Rackspace for stepping up and fixing a number of issues and helping work with our community to get this released.

The following issues were fixed in this release:

  • KNIFE_RACKSPACE-32 Ensure hint file is created to improve Ohai detection.
  • KNIFE-181 correct mixed use of ‘rackspace_auth_url’ and ‘rackspace_api_auth_url’. Only ‘rackspace_auth_url’ is correct.
  • KNIFE-182 default to Rackspace Open Cloud (v2)
  • KNIFE-267 Rackspace server create with networks
  • KNIFE-271 Enable winrm authentication on knife-rackspace
  • KNIFE-281 pass https_proxy and http_proxy setting onto fog; added ssl_verify_peer setting to disable certificate validation
  • KNIFE-282 Add the ability to inject files on server creation
  • KNIFE-289 Add Integration Tests

There is 1 known issue, but it should not affect Rackspace users directly and we’re working on a fix.

  • KNIFE-296 knife-windows overrides -x option with winrm-user

Contributors to this release included Adam DePue, Chris Roberts, Max Linc, Zack Feldstein, Steven Danna and Kyle Rames. Thanks a lot everyone!
https://rubygems.org/gems/knife-rackspace

Thanks,
Matt Ray
Cloud Integrations Product Lead :: Opscode
512.731.2218 :: matt@opscode.com
mattray :: GitHub :: IRC :: Twitter