Supermarket in Azure


#1

I am having problems getting a private supermarket installed in Azure. The DNS name and the FQDN are different because I have no choice. When I try to navigate to the page it wants to take me to https and it truncates the FQDN so its just the computer name. The makes the page not render.

Am I missing a step or is there something that needs to be changed in Azure?


#2

Hello,

When Supermarket does the redirect it will use the FQDN of the machine as it has been configured. If the machine does not have an FQDN then it will default to the shortname.

Is the FQDN of the machine resolvable in DNS? I know you state they have to be different, but the machine has to be resolvable. Why do you have to have different DNS and FQDN? Is it because of an internal network?

Russell


#3

Russell,

Thanks for the reply. I am setting this up in Azure and the FQDN has a long and ugly name when you set it up because it is an internal name. Similar to this jenkins.bamgcosbfesezjuviurhzvlh1d.dx.internal.cloudapp.net. I was able to change the FQDN to the DNS name and it started to work. I also added it to the /etc/hosts to make sure there wouldn’t be any problems resolving. Thanks again.


#4

Perfect, I am pleased you have got it sorted.

Are you using an ARM template to build your machine? If so then you can get Azure to pass the FQDN of the Public IP address to the machine and then set it using cloud_init.

Let me know if this is of interest and I will show some examples.

Russell


#5

Sure, I would like to see examples. I am currently not using templates but it would be nice to know in case we go that route in the future.

Thanks,

Mark