Chef-provisioning-docker Gem::ConflictError


#1

I’m running into the following error trying to
use chef-provisioning-docker with chef server 11.

Gem::ConflictError

Unable to activate chef-provisioning-docker-0.6, because
chef-provisioning-1.1.1 conflicts with chef-provisioning (~> 0.9)

root@vagrant:~# chef -v
Chef Development Kit Version: 0.6.0
chef-client version: 12.3.0
berks version: 3.2.4
kitchen version: 1.4.0
root@vagrant:~# gem list | grep -i chef
chef (12.3.0)
chef-dk (0.6.0)
chef-provisioning (1.1.1, 0.20.1)
chef-provisioning-aws (1.1.1)
chef-provisioning-azure (0.3.2)
chef-provisioning-docker (0.6)
chef-provisioning-fog (0.13.2)
chef-provisioning-vagrant (0.8.3)
chef-vault (2.4.0)
chef-zero (4.2.1, 1.5.6)
cheffish (1.2, 0.10)
chefspec (4.2.0)
root@vagrant:~# chef-client -v
Chef: 12.3.0